PDA

View Full Version : urgent help - disks locked after running SD


jasleinstein
07-27-2008, 05:34 PM
After purchasing and running SD the first time both disks (the original and the copy disk) are locked. We are unable to create any new folders on either drive. While logged on as the admin, under sharing and permissions is the phrase "You can only read". The Icon of the two drives shows a padlock on the lower left hand corner. We have tried every combination of checking the ignore ownership, apply changes to enclosed items, etc.
We have a three drive system. One for system files, which is fine. The second is a 2TB raid drive for photos, the third is another 2TB backup of number 2. We have been using the drives for many months, performing manual backs so we sure SD has caused this problem.

Apple support tells us the only answer is to format both drives and start over.

dnanian
07-27-2008, 05:47 PM
As I've said in support email, I can't see how we could possibly have 'locked' your drives. We don't change the locking status. We do turn "ownership" on for the drive, but that wouldn't lock it, and you can readily revert by turning ownership off in Get Info. For some reason, OSX isn't allowing that -- I don't know why that would be.

Apple Support also seems to be incorrect in this case. Formatting a drive in this situation makes no sense.

It's possible your 'volinfo.database' is wrong. Please follow the steps to delete the file in this FAQ entry (http://www.shirt-pocket.com/forums/showthread.php?t=318), then restart your Mac and try turning off ownership again.

jasleinstein
07-27-2008, 06:42 PM
Thanks for the quick reply Dave. I followed the instructions using the finder method. Put the DB file in the trash. Restarted. Went back to get info for the drive, unlocked the padlock, clicked "ignore ownership,,,," pressed the apply button, waited for it to complete. Same issue there.

dnanian
07-27-2008, 06:44 PM
It won't turn ownership off? For either drive?

jasleinstein
07-27-2008, 06:55 PM
I am a photographer not a technical guy.
Sorry for the stupid question how do I tell if ownerships is turned off after doing this?

dnanian
07-27-2008, 06:59 PM
If the checkbox is checked, ownership should be off. You'd open Get Info for the volume again and look to see if the checkbox is checked.

jasleinstein
07-27-2008, 07:09 PM
OK. Thanks. Yes the box is checked on both drives. The line after Sharing and Permissions states "You can only read.
Under Name/privilage it shows each name has Read&Write.
The Icon of the disk has the padlock on.

dnanian
07-27-2008, 07:19 PM
Have you tried repairing the disk with Disk Utility? I don't see how, if permissions are off, it would indicate that you can only read, since with permissions/ownership off you can do whatever you want to the drive.

jasleinstein
07-27-2008, 07:42 PM
I just ran disk utils. First verify - no errors. Then Repair. - No errors.

dnanian
07-27-2008, 07:50 PM
Something peculiar is going on here, certainly. Let's try the following. Open the Terminal application. In there, type the following:

sudo nouchg "/Volumes/Name of Drive"

where "Name of Drive" is the name of, say, the destination (backup) drive, so we don't mess around with the original. So, if that drive's name is "Photo Backup", you'd use:

sudo nouchg "/Volumes/Photo Backup"

Press Return at the end of the line, and type in your password when prompted (it will be invisible). Press Return when the password is entered.

Then, look to see if you can change that drive.

jasleinstein
07-27-2008, 08:02 PM
the name of the drive is backup.
I entered sudo nouchg "/Volumes/backup"
then it prompted me for password. I entered that
it replied sudo: nouchg: command not found.

dnanian
07-27-2008, 08:05 PM
Gah, my error. The command should be:

sudo chflags nouchg "/Volumes/backup"

Apologies.

jasleinstein
07-27-2008, 08:22 PM
bingo!! that did it! thanks a zillion.

dnanian
07-27-2008, 11:39 PM
Great. Now, do the same for the original volume, and that'll clear both up. Note: we did not mysteriously turn this on -- it was already on, for some reason. I don't know what might have done it -- but, now that it's off, it should remain so!