PDA

View Full Version : Response of Intego/VirusBarrier to it new update crashing SuperDuper


grmlaw
07-24-2008, 04:26 PM
Dave,

Here's the long awaited response from Intego to the facts its recent program update crashes SuperDuper:

"We have had reports of similar issues, which were escalated to our developers. After investigating the issue with VirusBarrier 10.5.3.1 and SuperDuper our developers have concluded that an update to SuperDuper will be require to resolve this. In the mean time you can add /Library/Intego into VirusBarrier trusted zone and your clone should complete without issue."

dnanian
07-24-2008, 05:37 PM
To repeat what I posted to your previous posting of this information:

Unfortunately, they're incorrect. Adding /Library/Intego to the trusted zone doesn't work, according to the users I've forwarded that to.

It's regrettable that they're pointing fingers at us, when the problem certainly seems to be in their court. It's one thing to deny access to an infected file: the user is then alerted that the file is infected, and can take action to remedy the situation.

It's another thing entirely to install files onto a drive that can't be copied due to the action of their kernel extension, and not even allow the files (which have rather bogus names with single byte ASCII characters that are typically 'invisible' to the user) to have their date/time information retrieved, even from a process that's running with root privileges.

Intego needs to have a bit more respect for their users than they're showing, I think. Scanning for (nonexistent, I might add) viruses should not prevent users from copying their completely uninfected drives.

drmoss_ca
07-24-2008, 05:40 PM
I have had the same reply from Intego today. My response? Uninstall Virus Barrier! I'm not quite sure why I was stupid enough to buy it anyway, but it certainly is a far less valuable tool than SuperDuper, even though it cost more. It will have to go by the wayside.

Chris

RonaldPR
07-25-2008, 02:46 PM
The reaction by Intego is outrageous. The problem clearly is caused by VirusBarrier X5 after the 10.5.3 update. If you do in Terminal:
cd /Library/Intego/virusbarrier.bundle/Contents/Resources
ls -le

You will find that the four files at the top of the list are the ones that cause the problem (trimmed the rest of the list):
ls: \001: Operation not permitted
ls: \002: Operation not permitted
ls: \003: Operation not permitted
ls: \004: Operation not permitted
total 3256
-rw-r--r-- 1 root wheel 132 18 jul 00:01 ActivatedArchives.dat

The solution suggested by Intego does not work.
However, disabling Real-Time Scanner before you start the backup will enable SuperDuper! to complete the backup normally.

Interestingly, when you look for the four files in virusbarrier.bundle while Real-Time Scanner is disabled, the files appear to be changed:
-rw-r--r-- 1 root wheel 0 18 jul 00:01 ?
-rw-r--r-- 1 root wheel 0 18 jul 00:01 ?
-rw-r--r-- 1 root wheel 0 18 jul 00:01 ?
-rw-r--r-- 1 root wheel 0 18 jul 00:01 ?
-rw-r--r-- 1 root wheel 132 18 jul 00:01 ActivatedArchives.dat

And after re-enabling Real-Time Scanner the list looks again as before.

Now, doesn't this point to VirusBarrier as the culprit ?

ncmphoto
08-02-2008, 11:31 AM
However, disabling Real-Time Scanner before you start the backup will enable SuperDuper! to complete the backup normally.

Before coming to this forum I discovered the same problem with my recently updated version of Virus Barrier - stops SuperDuper cold! Tried logging in without login items but no joy. Launched Virus Barrier and did try disabling Real-Time Scanner just for kicks, but that didn't work for me either.

What did (though it's a PITA and not a long-term solution) was rebooting in Safe Mode and then running SuperDuper which finally succeeded in finishing the Smart Update backup. At least I now have a current clone.

dnanian
08-02-2008, 11:46 AM
I've not seen another case where disabling real-time scanning didn't work; perhaps you didn't disable it fully?