View Full Version : Did SD! change the partition type?

07-21-2008, 12:18 PM

I'm replacing the 60GB drive in my 2GHz Intel MacBook running OSX 10.4.11 with a new 120GB drive. After attaching the new drive via USB and placing a GUID partition on it with disk utility I copied the files over from the internal drive using SD!'s "backup all files" script. After swapping the drives everthing boots and runs fine but disk utility now reports the new hard drive's partition type as APM, not GUID.

Did SuperDuper! change the patition type on my new hard drive?

07-21-2008, 12:20 PM
No, we don't touch the partition type: you need to partition it properly before you use SuperDuper!

07-21-2008, 12:43 PM
If that's the case then I must have only thought I had it set to GUID. I'm sure the sun was in my eyes at the time! I'll carefully do the upgrade again and see what happens.

By the way, everything seems to work fine with it set as APM. Is GUID required for the Intel MACs or is it only necessary if you want to run Windoze too?

07-21-2008, 12:59 PM
Well -- under Leopard GUID is strongly encouraged. APM works, but the installer won't install to it, etc. You're better off, especially for internal drives, using GUID.

07-22-2008, 12:49 PM
I realize now that on the first attempt I forgot to click my heels 3 times before using disk utility and therefor the GUID partition didn't stick to the disk.;)

Second time worked liked a charm and now it's on to upgrading to Leopard. Thanks for the great product and speedy help - I'll definitely be registering my copy to help support the cause.

07-22-2008, 12:57 PM
Appreciated -- and glad it worked the second time through. I guess you can go home again!