PDA

View Full Version : Help: I cannot see my back-up drive


istara
07-15-2008, 05:41 AM
My MacBook Pro bricked this morning so I am currently using my friend's MacBook. I did a SuperDuper back up last night before the bricking (yay for regular backing up) however when I plug the external drive into the MacBook, I can't see the partition that SuperDuper uses.

If this is to be expected between different types of Mac then fine. However I am a little anxious because the new MacBook Pro I have ordered will obviously be a later model than the former one. Will it be able to see the SuperDuper partition?

The external drive is working fine, because I can mount its general files partition. It's just the part that SuperDuper uses that I can't see.


EDIT: further to the above, when I run Disk Utility I can see the SuperDuper partition but it is greyed out. When I run a Verify on it I get "invalid sibling link".

dnanian
07-15-2008, 08:24 AM
That's not good. Did it brick with the drive attached? It's possible that the system locked up with the drive in an 'unflushed'/'busy' state.

I'd try repairing the drive with Disk Utility or, if that fails, Disk Warrior.

istara
07-15-2008, 08:44 AM
Possibly it did brick with the drive attached. I did have to force quit Super Duper last night, but it had reported a successful back up, I just couldn't close the windows. This sometimes happens when SuperDuper pops up for its scheduled back up when the drive isn't attached, and I plug the drive in during. But it always seems fine.

I've never plugged SuperDuper in to a MacBook before so I have no way of knowing if it should be showing the partition or not.

dnanian
07-15-2008, 08:48 AM
It should be showing the partition: it's not beacuse the partition structure is damaged. (The Force Quit isn't related: that was because the schedule fired with the drive missing, Cmd+s before quit will work around the issue.)

istara
07-15-2008, 09:01 AM
I did try to boot off it this morning when my laptop was bricked, but that didn't work. I don't know if that affected it though (I was holding down C instead of Alt so it wouldn't have worked anyway - however the Genius couldn't boot me off his external drive either). So I'm not sure if there was a problem with the back up before then or what.

Well I found some instructions relating to the "sibling" error here:
http://mahalkita.nanogeex.com/2007/09/28/how-to-fix-the-invalid-sibling-link-error/#comment-4386

so I tried that and got:

** /dev/rdisk1s12
** Checking Journaled HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
** Rebuilding Catalog B-tree.
** Rechecking volume.
** Checking Journaled HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
Incorrect number of thread records
(4, 22540)
** Checking multi-linked files.
** Checking Catalog hierarchy.
Missing thread record (id = 240)
Invalid directory item count
(It should be 0 instead of 2)
** Checking Extended Attributes file.
Incorrect number of Extended Attributes
(It should be 53257 instead of 53258)
Invalid leaf record count
(It should be 53475 instead of 53476)
Overlapped extent allocation (file 4 Catalog BTree)
Overlapped extent allocation (file 1172355 /.hotfiles.btree)
** Checking volume bitmap.
Volume Bit Map needs minor repair
** Checking volume information.
Invalid volume free block count
(It should be 9167124 instead of 7572373)
Volume Header needs minor repair
(2, 0)
** Repairing volume.
** Look for links to corrupt files in DamagedFiles directory.
Bus error

I'm now running it again just to see what happens the second time. It's very odd and annoying. I am just praying that the data is recoverable on the drive in my bricked laptop, because if not I am very seriously majorly screwed.

istara
07-15-2008, 09:19 AM
Oh my god that worked - after the second time it repaired successfully! And when I unplugged it and plugged it back in, I can see all my data there! YAY!!!

You have absolutely no clue how miserable I was feeling before: laptop a brick costing $4k to replace, and no back up or access to my most crucial data.

Anyway I will paste the instructions from that other thread:

-------------------------
Inside Disk Utility, select Disk Info, and take note of the ‘Disk Identifier’ value. Then click Unmount.*

Now open Terminal (under Applications, Utilities) and try the following:

fsck_hfs -r /dev/<the disk identifier value which you noted>
------------------------

*For me the only option was Eject, which is what I used.

dnanian
07-15-2008, 09:26 AM
Glad you were able to repair it!