PDA

View Full Version : Dashboard Widgets won't update in Sandbox


Impish
06-12-2008, 01:43 PM
Count me another satisfied customer of SuperDuper. I'm regularly running from a Sandbox, and occasionally doing a Smart Update of my MacHD, after which I always return to my Sandbox for daily use.

The only thing I've had trouble with is that I'm not able to update any widgets in my dashboard. That is, the installation of new versions appears to go smoothly, but when I'm done the old version is still there (and telling me an update is available).

I searched the SuperDuper help files for anything related to "widgets" but it returned no results.

Has anyone else experienced this? Is there something about widgets that prevent them from installing in a Sandbox system? Any ideas what to do about it?

Thanks!

dnanian
06-12-2008, 03:11 PM
That's interesting. Widgets are (usually) stored under your regular home folder, and as such should be shared like any other file. It's possible that the widget updater isn't properly resolving the path.

Have you tried downloading the new widget manually and installing that way?

Impish
06-12-2008, 08:17 PM
Have you tried downloading the new widget manually and installing that way?

That's the way I've always done it: download the new version, double-click and click "Keep" in the widget's window appears in the dashboard.

Even after this, the older version of the widget appears the next time I call up the dashboard.

dnanian
06-12-2008, 08:34 PM
Strange. I can only guess that it's not expecting to move the bundle across 'devices'. Alas, I don't think there's anything we can do...