PDA

View Full Version : Data Corrupt in Sparseimage


JustCallMeRich
06-02-2008, 04:30 PM
I just made a backup of a users OS 10.5.2 drive (sparseimage) and compared the original and the image - they were very close with the image being a couple GB less (this is common). Everything went smoothly, no errors. We erased the users drive and reimaged it with a new disk image, then copied the image back to the users desktop so they have access to their old files.

But when the user tries to open most of the files, the are damaged and will not open. I have tried Excel files, .jpg files, .ai files, word files, etc - and all give various error messages stating that the files are corrupt/damaged. Copy a file to another computer and it still does not open - still says damaged.

The odd thing is that the file sizes seem valid - they seem to be the correct size and take an appropriate amount of time to copy, and even have the correct icon.

The OS runs, the applications launch - but most of the data is corrupt/damaged.

I am going to try to reimage a spare Mac with this image to see if the data can be recovered this way. Any ideas?

dnanian
06-02-2008, 04:40 PM
What was this image stored to? Do you have the log created when this image was originally copied?

JustCallMeRich
06-02-2008, 05:19 PM
I was helping a new tech learn how to do this, but if I recall correctly, we were copying it to an external hard drive - can't remember if we were booting from the internal or external drive.

Would the partitioni scheme of the external drive have anything to do with it?

JustCallMeRich
06-02-2008, 05:20 PM
No, I don't have access to the log. We did two Macs and the other one is fine.

dnanian
06-02-2008, 05:22 PM
If the drive wasn't HFS+, which prevented the image from growing, it could. Have you tried repairing the disk image with Disk Utility?

JustCallMeRich
06-02-2008, 05:44 PM
The final image matched (within 2-3GB) of the original disk size. I am trying to get a local copy now and will try Disk First Aid and DiskWarrior to see what I can fix. I am also planning on reimaging a Mac here in the lab with this image to see if it still shows the problem after a restore.

I don't know what format scheme the external drive was. If it was one of the ones I set up, it would be HFS+ Journaled.

Not all of the data is corrupt. But the majority of the user data is unable to be opened.

Maybe I can run DFA/DW on the mounted image?

JustCallMeRich
06-02-2008, 05:46 PM
Also, when I double click the image to mount it, it goes through the disk check process with no errors and mounts fine.

dnanian
06-02-2008, 05:49 PM
OK. Send me an email to support and we'll go through some terminal stuff to take a look.