PDA

View Full Version : Unable to boot-up from a concatenated RAID set


Philip playfer
05-20-2008, 01:22 PM
I have a Mac pro (running Leopard 10.5.2) which in addition to my 750 GB hard drive contains two additional 300 GB hard drives. I have combined these two hard drives into a concatenated RAID set using Apple disk utility and backup my main hard drive to this disk using SuperDuper.

I have not tried to boot up from this RAID set for a while now, however, when I tried yesterday I was repeatedly unable to do so. The machine just crashed at start-up and I had to do an emergency restart. I have been able to boot from this set in the past. I would be grateful if anybody can help with this problem. I have been using SuperDuper for quite some time now as part of my backup routine, and it has been a real life saver in the past.

dnanian
05-20-2008, 03:53 PM
Two things. First, make sure you've done the 'fix' at the top of this forum. Second, in Terminal, run:

sudo bless --folder "/Volumes/your-backup-volume/System/Library/CoreServices" --bootinfo --bootefi

substituting your volume name appropriately. Press Return at the end of the line, type your password (which will be invisible) and press Return again. Then try booting.

Philip playfer
05-21-2008, 07:05 PM
No luck I'm afraid! I tried both the things that you suggested and upon startup I still got the 'grey international screen of start-up death' telling me that I have to restart the computer by holding down the emergency start-up key. Have you any other suggestions?

The only thing that was different to your instructions was that when I was in terminal it automatically asked for my password after I had entered the script and before I was able to press return. As a result I just typed my password as requested and then pressed return. You'll have to forgive me I know very little about working within terminal.

One other thing that is perhaps worth mentioning is that when I held the alt key, upon restarting the computer, in addition to my main hard disk the RAID came up as two separate discs one named RAID 1 and the other as RAID 2. Only RAID 1 was selected as the start-up disk. This may be normal, I don't know?

dnanian
05-21-2008, 07:46 PM
Well, that's a kernel panic. I'm not sure what would be causing the panic, but if you can send me the panic log from /Library/Logs on the backup drive, I can try to see what it's complaining about. Send it to the support email address.

Philip playfer
05-23-2008, 10:13 AM
Thank you Dave for your help on and off forum! The problem seems to be sorted. I had to take the rather drastic step of reformatting the two drives and redoing the RAID set. I then reinstalled Leopard, carrying out all the necessary updates. I did this just to check that it was possible to boot from the concatenated RAID set. Having satisfied myself that this was okay, I then did a smart update using SuperDuper making sure that the "fix_prebinding.sh" was set up to run at the end of the copy. The result of all this is that I can now boot from the RAID disk. Again many thanks for your help!

dnanian
05-23-2008, 11:22 AM
Glad to hear it!