View Full Version : Automating Backup Execution

05-22-2005, 05:53 PM
I'm a paid user of SuperDuper V 1.5.5, and I'm anxiously awaiting a scheduling GUI.

In the meantime, I've tried to follow the instructions in Section 12, on using an Applescript.

I've ended up with Daily Backup.sds in the /User/lotec/Library/Application Support/SuperDuper!/Saved Settings

What's interesting about this file is that Mac OS X thinks it's a NeoOffice/J Document, and fires up Open Office when double clicked.

Should the be a Superduper file or an Applescript file type ?

What do I need to change in order to straighten this out.

I'm assuming that I can execute this Daily Backup.sds script by hand in order to test out the execution. Right now, double clicking the file opens Open Office.

Thanks for some clues.


05-22-2005, 06:03 PM
Hi, lotec.

You're part way there. The "sds" file should be associated with SuperDuper! -- I'm a bit surprised it's opening OpenOffice. But, that's OK, at least for now, since you won't be using it that way.

You now need to drag the "Daily Backup" application, from the Extras folder of the SuperDuper! image, into /Applications. That's what you're going to run "by hand" to test the schedule -- and that's what you schedule with Cron or iCal.

Let me know if that fixes things.

05-22-2005, 08:16 PM

Thanks for the very quick reply, especially on a Sunday afternoon.

Yes that clarifies things. I had set my crontab up to run the sds file, instead of the Applescript in Applications.

I double clicked on the Applescript in Applications, and got started with the backup.

I'll know for sure tomorrow morning, as my automatic backup is scheduled to run around 4:00 am each morning.

Thanks for the fast assist.


05-22-2005, 08:21 PM
Glad to hear that made sense! We'll see what happens at 4:01! :)

05-23-2005, 02:20 PM

Nope, I don't think it worked.

I was expecting to see some entries in the SuperDuper! log, and there are not any for May 23.

I do show the system log running cron ok.

May 23 04:11:00 blazer CRON[833]: (mdm) CMD (/usr/bin/open "/Applications/Daily Backup")

When I double click on Daily Backup in the Applications folder, it fires up SuperDuper! and says job is going to start running in 9 seconds. I let it get started and it takes off fine.

So either my cron job is not pointing to the right file, or I have permission problems right off the bat, because there are no SuperDuper! log entries.

Any suggestions on how to trouble shoot this ?



05-23-2005, 02:28 PM
The actual file is "Daily Backup.app" (finder hides the .app part) -- you should pick it from the file picker. Once you've got that right, it should work...

05-24-2005, 03:56 PM

You are most correct, and it is now working :-)

You sure do have to know a lot of trivia to support all of us people out here, with the most mundane things that we can get wrong.

Congratulations on being up to the challenge and good luck bring Version 2 out.


05-24-2005, 04:01 PM
Great to hear. Sometimes, actually, support is a matter of looking at things with *no* knowledge -- otherwise, it can be hard to see what's wrong!