View Full Version : schedule firing at wrong time PM not AM

03-14-2008, 10:46 PM
I have SuperDuper and some iCal events scheduled for 3AM, but they are
firing at 3PM. I've checked System Preferences date & time and everything
shows as correct. Is there some cron file that could be corrupt?

03-15-2008, 12:03 AM
Not if both are going wrong: iCal doesn't use cron.

03-17-2008, 09:19 PM
I have exactly the same problem - seems to be a limitation of iCal - it only does it when the system is set to 12hour time - if it is set to 24hour time all seems to work fine. I find the 24hour time so hard to understand!

03-27-2008, 09:10 PM
I have my Leopard box set to 24-hr time, and SD is still running my evening backups in the morning, 12 hours from when it should.

03-27-2008, 09:38 PM
Make sure your locale is also somewhere that uses 24-hour time...

03-27-2008, 09:54 PM
My problem involved two sources.

My iCal events times had been reset. Reset them and they work.

Then had to figure out why SuperDuper was misfiring. Finally tracked it down to my Schedule for Sleep. The schedule reverted to an old schedule where it put the computer to sleep not giving SuperDuper time to complete. I unchecked it and now SuperDuper puts the computer to sleep as directed.

All of this happened after applying the Combo updater.