View Full Version : Restart after cloning boots from clone??

03-05-2008, 06:44 AM
Can someone help me figure out why it is that after successfully cloning my primary startup drive (Intel MacPro | 10.5.2 Leopard), subsequently restarting my computer results in my computer booting from the newly cloned drive (firewire 800 external drive), and not my regular preferred internal drive as it should?

Any suggestions would be greatly appreciated... Thanks!

03-05-2008, 08:54 AM
The fix for me was to run maintenance using disk utility - I had lots of erros that needed fixing (disk warrior still not 5.2 compatible yet) from the clone, repair permissions, and using leopard cache cleaner, to clean all caches (deep cleaning). I suspect something in my boot cache was screwy in addition to the fixes done by disk utility. Before doing that I reset the pram and fixed permissions (which didn't solve the problem). You might want to start with pram reset as that is where the machine stores boot info. Also, are you sure your battery is holding up ok? At least for me, all is now well. Other weird symptoms I had included various cloned boot drives not having proper names when I booted using option key.

03-05-2008, 11:02 AM
Are you sure the drive isn't set as the startup drive in the startup disk preference pane?

03-05-2008, 07:46 PM
Are you sure the drive isn't set as the startup drive in the startup disk preference pane?I am absolutely positive that it was not ...correct me if I am wrong, but the only way that the 'wrong' drive can be selected in the startup disk preference pane is if its been selected manually....I did not manually switch anything, but sure enough upon restarting my computer, it definitely chooses to reboot from the cloned drive and not the primary OS as it should boot from...
The fix for me was to run maintenance using disk utility - I had lots of erros that needed fixingI will try to run some maintenance programs like Leopard Cache Cleaner, Cocktail and Onyx while booted from the clone drive, then re-run the SuperDuper and see if it happens again...if it does, I'll just reformat the clone drive and write zeros to it, then use SuperDuper to completely erase then copy the drive again from scratch...I am sure that will work (said with my fingers crossed behind my back)...

I'll let you know how it turns out...

03-05-2008, 08:18 PM
No, that's not the only way: it could also happen if you've selected an "On successful completion" option in SD! to set the backup drive as the startup drive... but if you open it, and select the internal drive, and restart a few times, that'd tell you whether simply resetting the current choice will "fix" the problem.

03-05-2008, 08:45 PM
I just have it configured to quit superduper upon completion...Here are my settings...



03-05-2008, 10:09 PM
The settings in the Option window are not the settings in the scheduled copy, though. Click "Show Log" in the Scheduled Copies window and send me the log with the "Send to shirt pocket" button.

05-04-2008, 02:06 PM
I can confirm that this exact same thing happened to me. I ran a successful copy of my main drive to my backup drive using SD. Immediately after, I restarted my computer (did not change the startup drive), and my settings in SD were to do "nothing" upon successful completion. When my computer restarted, it was the backup that it booted from. My backup drive was listed in the top right corner and the system was running off of it. Not a big deal as I just changed my startup disk back to my main hard drive, but I had no idea why it did this. I then found this thread. By the way, I am running Tiger 10.4.10 on a PowerPC G5. Thanks

05-04-2008, 02:22 PM
Was it a scheduled copy or a manual one?

05-04-2008, 02:24 PM
Scheduled. I was just sitting there making sure it did everything right, because I set it up to automatically turn my computer on at a certain time, and then run SD. I then restarted my computer immediately after.

05-04-2008, 02:54 PM
Right. What you need to do is look at the log *for the schedule*. Check that by opening the Scheduled Copies window (Window > Scheduled Copies). Click the schedule, then click "Show Log".

Once you're there, scroll to the bottom and copy the last 10 lines or so into a reply here.

05-04-2008, 03:15 PM
| 03:09:53 AM | Info | ...ACTION: Making Macintosh HD Backup bootable
| 03:09:53 AM | Info | ......COMMAND => Blessing OS X System Folder
| 03:09:54 AM | Info | Successfully blessed Mac OS X folder on Macintosh HD Backup
| 03:09:54 AM | Info | ......COMMAND => Blessing OS 9 System Folder
| 03:09:54 AM | Info | Did not bless Mac OS 9 System Folder on Macintosh HD Backup because it does not exist.
| 03:09:54 AM | Info | ...ACTION: Restoring Spotlight state on Macintosh HD Backup
| 03:09:54 AM | Info | ......COMMAND => Restoring Spotlight search indexing state on Macintosh HD Backup
| 03:09:54 AM | Info | /Volumes/Macintosh HD Backup:
| 03:09:54 AM | Info | Indexing enabled for volume.
| 03:09:54 AM | Info | Indexing enabled on Macintosh HD Backup
| 03:09:54 AM | Info | Copy complete.

05-04-2008, 03:21 PM
OK. Assuming this is the log from the run that you're talking about, we didn't set the drive as the startup drive. How it became the startup drive I truly don't know: but we didn't run the command that's required to do it...

05-04-2008, 03:45 PM
Yeah, I don't know. It's not even a big deal, I just changed it back myself manually...I just thought it was odd that the same thing happened to someone else too. Not really sure what the problem was.

05-04-2008, 04:46 PM
Understood. It is quite weird, and not something I've experienced. I don't even really know how it could happen, with or without SuperDuper. Bizarre.