View Full Version : Mount Sparseimage - what is happening?

03-03-2008, 12:47 AM
Hi. I backup to an NAS, so that creates a sparseimage. I have SD! set to run every night at 9:30 using smart update. I've noticed that it takes a *really* long time to mount the sparseimage (we're talking 3+ minutes over gigabit lan, and 15+ minutes over wireless). Why is that? What is it doing? According to iStat Pro, it looks like my computer is downloading a butt-load of data. What data does it need? I figure it's not just my computer, because I've tested this using a directly-attached firewire drive and there is essentially no time (though, that's not sparseimage).

It's all working just fine, I'm just curious. Thanks.

03-03-2008, 08:52 AM
As of 10.4.9 or so, OS X started to scan every image that's mounted to make sure it's valid for security purposes. It takes a long time to do.

03-03-2008, 11:13 AM
Is there any way to bypass that? Since I know what this image is, can I set some security parameter to allow easy access?

03-03-2008, 01:56 PM
Not that I know of.

03-06-2008, 02:56 PM
Within a week, either our Sparse Image backups end up corrupted or Super Duper stops backing up for some other reason. I was so happy to kiss Retrospect goodbye when we first switched, but now it's becoming just as much hassle and work as Retrospect. SuperDuper always seems to time out or give up before our Macs are able to load the proper Sparse Images. Why can't SuperDuper back up to regular disks over a network?

Anybody figure out ways to deal with this stuff that doesn't take daily maintenance? It is just a $25 dollar program. Anyone using something better?

03-06-2008, 03:03 PM
Corrupted? If the images are becoming corrupted, it sounds like you're having some serious networking problems or other issues. SD! can only work as well as the environment it's running under.

We don't have any "timeouts", though, so I'm not quite sure what you're referring to here...

03-12-2008, 11:01 PM

I'm having the same problem as the original poster. I set up SD on a schedule to back up to a sparseimage I have a backup USB drive attached to an Infrant ReadyNAS NV+. I've been thinking that SD has been backing up just fine because I come back to my Mac and see the network volume mounted to the desktop. I had assumed that SD had mounted the Sparseimage on that volume, done it's backup and then unmounted the SI. A look at the log shows me that the last backup was the one I did manually 6 days ago!!!!

I tried doing a manual backup and SD took forever to mount the SI - it must have been 5 minutes or so but it finally came up and then it started the back up. However, SD DOES APPEAR to be timing out on scheduled backups because the log shows that a backup has not been completed.

So I'd love your suggestions as I consider this a bug. I need to schedule backups but SD is clearly 'not waiting' for the SI to mount even though it appears to do so if you do a manual backup.


03-13-2008, 12:33 AM
Well... a manual backup and a scheduled backup are actually exactly the same, so they'd run the same way. We have no timeouts -- do you get an actual error message?

03-13-2008, 11:45 AM

No, I don't get any error message when it is on scheduled back up. That is why I didn't know that the backups were not happening until I checked the log.

Today I will schedule a backup when I know I can be watching the computer and see what happens. I know that when doing it manually that it eventually mounts and the backup proceeds. It also leaves the SI mounted to the desktop unlike when doing a scheduled backup where it mounts the network volume but never gets the SI mounted.


03-13-2008, 11:50 AM
The log has no errors? What'd help is if you could send in the logs from one of these failed copies with the "Send to shirt pocket" button.

03-19-2008, 08:18 AM
OS: 10.5.2
SD: 2.5 v84

I too have had nothing but grief with network images and SuperDuper. It seems to fail (not mounting the image) most of the time. And to top it off, the Growl notification system is not reliable in telling you when it fails. In the end, I just gave up trying to debug the problems and attached a firewire disk as needed to each computer manually. Not really an ideal solution.

Now I have a TimeCapsule with a 500 GB internal disk and an external USB disk. I want to use TC as a NAS so I tried to backup to a sparse image on the external disk. It got about 1/3 of the way through after 4 hours (30 GB done) and I mistakenly put the MacbookPro to sleep. When SD woke up it said that it failed since it couldn't find the image. Understandable, although the finder seemed to remount the time capsule just fine.

In any case I tried to continue the backup manually: it tried to mount the image and failed. When I tried to mount it in the Finder it told me that the image was un-repairable. Apparently, putting SD to sleep in the middle of the clone trashed the image. I deleted the sparse image and set SD to try again tonight, but the fact that it trashed the image when stopped doesn't give me confidence that i will always have a recent bootable image. One interrupted backup and it could go through days or weeks of failing to mount the corrupted image without me knowing about it. And Murphy's Law being what it is ...

So now I really don't know what to do. Ready to give up on this whole idea. Anyone have any ideas on how to get this to work reliably and without constant attention from me?


03-19-2008, 10:13 AM
Sleeping your Mac in the middle of an active copy to an open file is a recipe for disaster. I've seen Time Machine corrupt its own archives in the exact same situation...

03-19-2008, 10:21 AM
That may be true, but it is unfortunate. In the real world processes get interrupted.

In any case I would appreciate some response to the long-term problems I have been having:
- unreliable backups (mounting problems) when backing up over the network.
- lack of reporting when something goes wrong. (To me this is a basic requirement of any backup solution).

Thanks for listening.


03-19-2008, 10:31 AM
If you're in a situation where the process gets interrupted, I strongly recommend that you not back up to an image, or -- if you do -- stop the backup and eject the image before you sleep the Mac.

Yes, "in the real world", things happen. But those things also have consequences. A system crash can corrupt a drive. Memory problems can cause failures. Disconnecting a network during a file copy can very likely corrupt that file. If you're writing to an image, you can corrupt the image... the system does the best it can to keep that image flushed, but it can definitely happen, to anything.

I don't have enough information to provide any detailed response, but in general:

- We mount images by asking the system to mount the network volume (if not there) and then mount the image itself. The network volume is mounted by resolving an alias to the image file itself (which mounts the drive). It's hard to know why that might fail without any error. You can try to mount the image by hand and then schedule with the volume (rather than the file) selected. That mounts a different way, and might help.

- v2.5 has fixed a problem with Growl reporting (in rare situations) that should work. Have you recreated your schedule since installing 2.5?