PDA

View Full Version : Do I need the new version?


jay
03-01-2008, 10:39 AM
Hello,

I have a non-intel iMac with OS X 10.4.11, with SuperDuper 2.1.4 (v82). The kids have newer MacBooks, with the intel chips, also OS X 10.4.11, also SuperDuper 2.1.4 (v82). They may at some point upgrade to the new Mac OS. On our older iMac we will not upgrade; we'll just eventually get a new computer and consider our old one to be in it's final state. Do I need the new SuperDuper for the old iMac? Do the kids need the new SuperDuper for their newer MacBooks, and if so, should they upgrade now, or, wait until they upgrade their OS?

Thanks,

Jay

dnanian
03-01-2008, 10:44 AM
It certainly doesn't hurt to update, since 2.5 is compatible with 10.4.x and 10.5.x.