PDA

View Full Version : Help with getting info from external SD copy to new internal hard drive.


MsMcGee
01-27-2008, 04:18 PM
After problems with getting SD to copy to iPod Classic I bought an external HD. Everything copied fine. Swapped out the hard drive and then started it up... It seemed to read the new hard drive. I copied the external hard drive over and not all the files went over, Library and Systems both gave errors that I did not have permission. Then when I disconnected the external HD the screen went grey with a weird panic debugger drive and it kept telling me to turn off the computer.

I ran a hardware test, ran disk utility and the new hard drive seems fine. I ended up reinstalling OSX from the original disks.

I used migration assistant to take my settings and files from the external to the internal but the only options are:

1) use a firewire to combine two macs (the external HD only has a usb)
2) combine from another volume or something. This option makes me add a new user and puts my settings on the new user ID.

I ended up erasing the new user when I couldn't figure out how to merge them. The new user also had a problem with FireFox.

I feel so close to being done with this hard drive swap. Help!

dnanian
01-27-2008, 04:25 PM
I'm quite confuI'm a bit confused. What were you copying Library and System with? If you started up successfully from the the copied drive, why are you then copying System and Library, and with what?

MsMcGee
01-27-2008, 04:40 PM
When the system booted up for the first time it was reading off the the external HD. I think I dragged and dropped the external HD to the Internal HD. Then the files started transferring...an Apple window came up and said something like "Library could not be copied because of permissions" Stop or continue? I selected continue, the same thing then came up with "system could not be copied" Stop or continue? I assumed that after more files copied something would pop up asking me for a password that would allow those two files to copy. After everything that could copy did, there was more space available on the internal than the external and when SD copied onto the external HD it said there were 290,000 files but when I copied external to internal, only 140,000 files copied.

When I unplugged the external HD, then the error started. When I installed OSX basic install, it would never ask for the second disk, it would give me that same weird error with "panic, debugger" thing. I did a custom install and left off the printer drivers and language pack and then was able to install osx.

Now I have my old hard drive on this external hard drive, how do I get my settings and files onto the new internal hard drive?

dnanian
01-27-2008, 04:54 PM
You can't copy external to internal with Finder, though. You need to use SuperDuper! to copy external to internal -- the same way, with "Backup - all files".

MsMcGee
01-27-2008, 05:49 PM
I tried that but it greys out the option of my new HD. I can select the external but cannot select the internal hd.

dnanian
01-27-2008, 05:54 PM
That's because you're not running from the external. You need to boot from the external.

MsMcGee
01-27-2008, 09:41 PM
okay. I did go back and boot from the external and used super duper to copy external to internal and all 290,000 files copied over but nothing has changed. My itunes songs are on the HD in the internal hard drive but when I open itunes, it wants me to register, same with iphoto. My dock is still the original osx installed dock.

What am I doing wrong?

dnanian
01-27-2008, 09:54 PM
When you booted from the external, everything (including the dock) looked fine there?

Are you sure you're not running Leopard?

MsMcGee
01-27-2008, 10:11 PM
I went back and checked, the external hard drive does not have all my settings saved either. If I click on the hard drive, click on users, click on the user I named best buy (where I bought the hard drive), click on music, click on itunes, all of my music is there. Same with photos and movies folder. But when I try to open itunes or iphoto, it starts with the "Welcome to itunes!" assistant comes up.

I do not have leopard.

dnanian
01-27-2008, 10:36 PM
I'm really not sure what's going on here. The original drive is still available?

How exactly did you make the copy? Was the "BestBuy" user the one that you checked with? And it didn't work at all when you started up from the backup?