PDA

View Full Version : Drive imaging/restoring issues


FSU_Math
01-22-2008, 02:16 PM
We use Superduper to create a default system image for all of the Macs that we deploy. In general it works great and there are no problems, but there have been a few errors that I'm hoping someone could tell me what I'm doing wrong.

1) Most recently was a 10.4.10 image that I installed onto several Macbooks. After installing it, I discovered that the machines were locking up when they tried to go to sleep. The actual OS did not seize, but rather the screen,keyboard, and mouse stopped responding. This was verified by pressing the power button, which immediatly refreshed the screen and displayed the "how do you want to power down" dialog. Pressing Cmd-option-eject was able to duplicate the problem every time. I eventually went back to an older image of 10.4.10 and have had no problems since. What could have happened to an otherwise working image?

2) On a different Macbook, I installed the system image and the user is now getting an error: "A valid video device could not be found for playback. [-700717]" There does not seem to be anything wrong w/ the DVD drive, but again, could Superduper have made a mistake in transferring the files?

3) My last question is what is broken with Superduper and 10.5? Does the program not operate in 10.5 correctly, or does it not transfer 10.5 images correctly? I know fixes are in the work, but I can't seem to find a list of what is broken.

Thanks in advance.

dnanian
01-22-2008, 03:19 PM
1) That's rather weird. What was the difference between the two images, older and newer?

2) Also strange: is, perhaps, this a newer MacBook? We've literally never seen a problem transferring files with SD that didn't generate an error... we are, after all, using the system to do it.

3) Backups aren't bootable in most cases, metadata/ownership/EAs/ACLs may be incorrect, and Smart Update isn't smart.

FSU_Math
01-22-2008, 03:40 PM
The main difference in the images is that one of them started out life as an image on a iMac and the other started out as a Macbook image. Over the last year there have been several hardware (I'm guessing) changes, in particular to Airport, that have made various images not work with newer systems and so I'm forced to start again. I sort of expect this to happen and its not a problem, but it ends up that I usually have several system trees that I can fall back on. In this case, the working image started out as a Macbook Pro in mid-June of 07, and the non-working came from a new iMac in the end of Nov 07.

I have used the iMac image several times with no problems, and updated it since by installing it on a system and doing Apple's updates so I'm thinking that on some copy there may have been a transfer error. I've never actually seen an error reported by Superduper so perhaps its in hardware at a level that Superduper is unaware of. Is there anyway to run a comparison or verify to make sure that a copy went off correctly?

dnanian
01-22-2008, 03:42 PM
Not without some other tool -- but there could be a hardware change that caused the image to be incompatible with later Macs... regardless of what copied it.

FSU_Math
01-22-2008, 06:00 PM
Are the problems with Leopard happening when using Superduper within Leopard or only when working with Leopard images? I.e. can I use Superduper under Leopard when working with 10.4 images with no ill effects or is this still not advised?

dnanian
01-22-2008, 06:05 PM
It's with both. I recommend not using it until 2.5 is out.