PDA

View Full Version : Having tons of problems booting Restored drive


macmedia
12-19-2007, 09:31 AM
I have a G5 tower. I had two 300gb drives set up as a RAID 1 (mirroring) in 10.3.9. I subsequently upgraded to 10.4.10. Well one of the drives failed and I proceeded to insert a new 300gb and rebuild. It ended up that I couldn't do so.
It wouldn't let me add a new drive to rebuild.

Anyway, I inserted 2 new 400gb drives and put the good remaining 300gb in an external enclosure. I booted up from an external FW drive running Leopard and formatted the 400gb as a RAID 1. I ran SD and cloned the 300gb drive into the 400gb. Everything worked fine and it looked like it blessed the 400gb but the very last step, I get an error message:
| 04:06:48 AM | Error | No pre-existing OF label found in HFS+ volume

I cannot boot into the new raid even though I can designate it as a Startup disk. When I start up the computer, the blinking icon is waiting for a valid startup disc. I can put the old single 300gb drive back into the computer and it boots up fine (albeit has a degraded RAID status).

I tried Disk copy and CCC 3 and both could not get the RAID to work as a startup.

HELP please!

dnanian
12-19-2007, 10:08 AM
You can't really do this from Leopard, macmedia: try formatting the drive from a Tiger startup drive...

coumerelli
12-21-2007, 01:10 AM
And double check that the partition scheme isn't MBR (which it won't be) or GUID (since it's not an Intel), but Apple Partition Map - otherwise it's not bootable. Also, external drives (at least up through 10.4.9) could only be booted if they were firewire, not USB. I'm sure Dave could confirm this as well.

Confirm the partition scheme in Disk Utility. If its the wrong one, then you need to highlight the disk (not the partition) and choose the partition tab on the right, choose "Options..." and select the Apple Partition Map. Hit OK and Apply. This will, of course, wipe the disk clean but it will have the correct partition scheme for you.

Just a thought.