View Full Version : odd issue with SD

05-05-2005, 02:05 AM
Well, I finally bit the bullet and registered SD!

I have an external Firewire hard drive that is partitioned into 3 partitions. The hard drive was daisy chained through an external Firewire DVD writer to my G4 running 10.3.9; my onboard Firewire ports are hosed and I am using a Sonnet Tango 2.0 Firewire/USB 2.0 card.

I had cloned my drive a few days before, so this time I just asked SD to backup changed files. I used the middle partition, called "Disk Images" as my target.

Right after SD finished, the partition unmounted by itself, and I got an error message saying there was an error on the disk. I rebooted, and ran Disk Warrior on all three partitions on the external drive. There were some minor repairs.

I then backed up again, without a problem, but the volume name that showed up in SD was "Disk Images 1", not "Disk Images", though in the finder the volume was still called "Disk Images".

After backing up, I tried to boot up off of the external drive by holding down the Option key, and my main hard drive did not show up, but "Disk Images" did. I selected "Disk Images", but the machine booted off of my main drive! I then unmounted the Firewire drive and turned it off, and rebooted again holding down the Option key. The only drive that showed up was "Disk Images" (but that drive is turned off!), and booting from that made the machine boot off of my internal hard drive. Somehow my system now thinks that the name of my internal hard drive is "Disk Images" (though it doesn't show up that way in the finder!).

I then mounted my external drive, went to startup disk and selected the external drive and tried to reboot. I got a blinking question mark.

So, after all of this:

1. My backup made with SD won't boot
2. My machine somehow thinks my hard drive has been renamed to the name of the external partition SD backed up to.

Any ideas how to remedy this peculiar state of affairs?

05-05-2005, 09:04 AM
It sounds like your FireWire drive failed during the copy process. When this happened, it partially unmounted without telling SD!, so SD! kept copying. If you detach the drive and look in /Volumes, you'll see a folder named the same as the drive ("Disk Images", I assume). That needs to be removed.

It sounds to me like your FireWire subsystem isn't necessarily reliable enough to support this kind of activity. You can try backing up again, but I'm concerned that things are flaky enough to prevent proper operation. I'd suggest trying to simplify the FireWire bus as much as possible: only attach the external drive, nothing else, then Smart Update the backup.

05-05-2005, 03:46 PM
Thanks for the response.

I'm going to try a different Firewire cable, in case that's the issue (I've read that poor quality cables can make a difference), and I'm trying an Erase and Backup so that any corruption that might have occured when the drive went bonkers can't have any "residual" effect.

Now, I'm interested in your response about the folder /Volumes. Does that mean that the way SD does its magic is to copy the drive into the folder in /Volumes and then, at the end of the process, copy it all onto the target location?

05-05-2005, 05:11 PM
Oh dear, no, not at all. /Volumes is where drives are mounted by OS X. A mounted drive looks like a folder in there. But if the drive "Vanishes", and the folder is left by orphaned, we can't always tell it's gone. If we keep copying, rather than going to the volume represented by the mount point, it goes into a folder.

It's rare, but I think it's happened in your situation.

05-08-2005, 02:24 AM
Well, it seems that a different firewire cable helps..at least partially. The backup completed (I did an erase and backup to make sure things didn't get mucked up).

BUT, the computer still won't boot from the backup. Two interesting symptoms:

1. If I select the external drive in Startup Disk and try to reboot, I get a blank gray screen for a while, then a blinking question mark alternating with a blinking "old" (Mac OS 9) style happy face

2. If I reboot the machine with the option key held down, the external drive does not appear in the list.

Is it possible that a drive attached to a firewire PCI card might not be recognized until sometime later in the boot sequence...with this perhaps differing from the situation with built in Firewire?

05-08-2005, 09:58 AM
It's definitely possible: can you simplify the bus, plug the drive in directly and see?

You also might want to unplug the drive, get to the Option selection screen, and then plug it in. Wait for it to spin up, then click the refresh button and see if it shows.

05-08-2005, 03:17 PM
Well, I can't plug the drive into my built in ports because they don't function any more (hence the need for a PCI Firewire card, alas). I will try your suggestion.

Also, in my Googling the issue, I have come up with ambiguous results. Some posts seem to indicate that Firewire booting does not work with an add-on PCI card...other posts seem to contradict that.

05-08-2005, 07:36 PM
Ah, OK. It doesn't surprise me that you're getting ambiguous results -- it's probably an issue with different combinations of computers, cards and drives...

05-08-2005, 11:26 PM
OK, I've tracked down everything and fixed it. This may be useful information for others:

1. My "fried" onboard Firewire ports were fixed by resetting the PMU and doing an Open Firmware reset (seethis Apple Knowledge Base article (http://docs.info.apple.com/article.html?artnum=95066) or search the Apple support site for "pmu")

2. The firewire drive that wouldn't boot when connected to a PCI firewire card booted perfectly when connected to the built in firewire ports.

SuperDuper! had made a good copy/clone, I couldn't boot from it until I fixed the firewire ports.

Thanks for all the help.

05-08-2005, 11:50 PM
Great to hear: thanks!