View Full Version : Frequent I/O exceptions on USB drive

12-12-2007, 07:57 AM

I hope I didn't miss a thread where this problem has already been discussed, but forum search didn't find anything appropriate...

I'm doing a full backup (Backup all files script) to a USB drive (Freecom Toughdrive 250GB). I created a self-expanding 128bit AES encrypted image on that drive and am trying to backup to it. This setup has worked on other occasions, but it's giving me trouble now for whatever reasons.

Here's what happens:

At different times during backup SD! stops with an error. The log looks something like this:

| 12:23:14 PM | Info | WARNING: Caught I/O exception(5): Input/output error
| 12:23:14 PM | Info | WARNING: Source: /Users/thomas/Library/Caches/DashboardClient/09/02/2288547999-2538855461.cache, lstat(): 0
| 12:23:14 PM | Info | WARNING: Target: /Volumes/Schniposa2/Users/thomas/Library/Caches/DashboardClient/09/02/2288547999-2538855461.cache, lstat(): -1
| 12:23:14 PM | Info | Attempting to copy file using copyfile().
| 12:23:14 PM | Info | Attempting to copy file using ditto.
| 12:23:14 PM | Error | ditto: /Volumes/Schniposa2/Users/thomas/Library/Caches/DashboardClient/09/02/2288547999-2538855461.cache: Input/output error

The error occurs with different files each time, so it's not the file that's causing the problem I guess. The strange thing is this: After this error the drive is "dead", meaning that if I reconnect it, I get a message saying the drive is not recognized. Disk Manager detects the drive but no partition whatsoever. After I initialize the drive again, it works again.

I've tried to backup directly without using an image, which worked fine. But I'd like to backup to an encrypted image because I take this drive with me when I'm not home, and I wouldn't want my data to be readable if I happened to lose the drive. Backing up to an image and moving that to the drive would be an option, but would take too much time.

Any ideas as to what might be causing this problem?


EDIT: Forgot to mention: SD! 2.14 (v82) on Tiger (10.4.11) on an Intel iMac 24"

12-12-2007, 11:37 AM
Sounds like you're having either communication problems on the destination drive or surface issues, Tom...

12-12-2007, 12:56 PM
Sounds like you're having either communication problems on the destination drive or surface issues, Tom...

I'm afraid I don't know what you mean by surface issues...

12-12-2007, 12:59 PM
I mean physical damage to the drive surface.

12-21-2007, 05:23 AM
Just finished checking the drive with TechTool Pro (ordered TTP online and had to wait for delivery...). You guessed right: the drive simply disconnects after about 50% through the surface check and TTP starts logging bad blocks. Seems funny that TTP doesn't seem to notice that the drive is gone, but whatever the issue is, the drive definitely has some sort of defect.



12-21-2007, 09:10 AM
Anytime, Tom. Glad you've got a handle on the situation.