PDA

View Full Version : no mountable file systems - error opening sparseimage file


crossbow42
12-03-2007, 02:15 AM
I did a superduper backup to a volume mounted on an Win2k server (long story!), and it backed up just fine. Now I find myself needing a file from said backup, and when I try to open or mount the sparseimage file, I consistently get the error "no mountable filesystems"

I tried this fix, I found on MacFuse:

$ cd /Volumes/temp/
$ com_apple_hdid_kernel=1 open foo.sparseimage

with the same error result.

Does anyone have any other suggestions?

Cheers!

dnanian
12-03-2007, 08:52 AM
Have you reviewed your backup log in SD! to see if you received any errors when you were writing this image? What filesystem was used on the server?

jefferyn
01-31-2008, 01:32 PM
greetings,
i have the same error message with my system... i'm attempting to backup for the first time to a network drive, since my regular back hard drive is now full... i have our sun disk nfs mounted to my mac. superduper created the sparse image file on the sun partition. but the backup halted with the error a few seconds after starting... i can open and mount the sparse image, but it has no files... i tried it 2 times... after the second time, i deleted the sparse image and tried the 3rd time. superduper created the new sparse image file and again halted with 45 sec elapsed time...

last few lines from the error log (with some of the computer names removed for security purposes)

| 08:51:44 AM | Info | created: /Volumes/xxx/yyy-netBackupA.sparseimage
| 08:51:44 AM | Info | ......COMMAND => Setting ownership and access modes for '/Volumes/xxx/yyy-netBackupA.sparseimage'
| 08:51:44 AM | Info | ......COMMAND => Mounting yyy-netBackupA
| 08:51:47 AM | Error | hdiutil: attach failed - no mountable file systems

i didn't see a solution to this thread. so i thought i'd pitch in my case to see if someone recognizes what is wrong...

thanks for any suggestions-

dnanian
01-31-2008, 01:52 PM
We're getting an error when we try to mount the image that it doesn't have any file systems in it. If you can mount it yourself, point SD! at the mounted image volume (rather than the image file) and back up to that...

VirtualWolf
02-23-2010, 06:56 PM
I'm seeing the same issue as the original poster. I've checked the logs in SuperDuper from the last backup and everything was copied successfully. The volume that the backup sparsebundle is being saved to is JHFS+, and is connected directly via FireWire. I've tried the "com_apple_hdid_kernel=1 open foo.sparseimage" tip above with no success.

Any thoughts?

dnanian
02-23-2010, 07:02 PM
"No mountable filesystems" means that the image itself is likely damaged. Perhaps start Disk Utility, drag the image into the sidebar (unmounted), select it and try to repair.

VirtualWolf
02-23-2010, 07:07 PM
Oh, sorry, I forgot to put that in the post, heh. That was the first thing I tried, and it verifies fine. :\

dnanian
02-23-2010, 07:17 PM
Then, does it open fine in Finder?

VirtualWolf
02-23-2010, 07:22 PM
Nope! It gives that "No mountable filesystems" message. It's really quite bizarre.

dnanian
02-23-2010, 07:50 PM
I can't see how Disk Utility could possibly repair the image if there's no filesystem in it. Don't verify - try repair.

VirtualWolf
02-24-2010, 04:16 AM
Nor can I! And there's a big giant "WTF" coming, although in a good way so far.

So I got home from work and booted from my 10.5 install disc to verify all of the drives in attached to the machine. All verified fine. Rebooted into OS X, dragged the SuperDuper sparsebundle into Disk Utility and clicked Repair, it said it passed verification. So I clicked Open in the toolbar.. and it mounted?!

As I type this Disk Utility is busily restoring the sparsebundle quite happily to a spare partition. WTF! Not that I'm complaining, mind you! :) I'd just love to know wtf happened.

VirtualWolf
02-24-2010, 05:14 AM
I've now booted successfully from the restored backup image on my spare partition. Now interestingly, when I went to mount the sparsebundle in the Finder in preparation for copying it back onto the internal drive of the Mac mini, I got the same "No mountable filesystems" error! I opened Disk Utility, dragged the sparsebundle into it, then selected it and hit Open in the toolbar, and it still didn't mount.

Even though the permissions on the whole sparsebundle is owned by the admin user and the regular user I run in isn't one, they're set to rwxr-xr-x, so I ought to be able to read the sparsebundle properly anyway. I logged into that admin account, and can mount the sparsebundle perfectly.

I had made a copy of it from my regular non-admin user on another partition, and in that same non-admin account I can mount /that/ copy fine! So it would appear to be some bizarre permissions-related thing that was preventing me from mounting it.

dnanian
02-24-2010, 09:38 AM
Really weird. No idea what that could be.