PDA

View Full Version : Restored 10.4.10 image exhibits strange behavior


Derekasaurus
10-01-2007, 12:25 PM
After reading a recent thread (http://www.shirt-pocket.com/forums/showthread.php?t=2687) that discussed strange problems some 10.4.10 users (including myself) have encountered after restoring an SD! backup, I learned that resetting the LaunchServices database is most likely the solution.

Unfortunately it turns out this is not the case.

To summarize, sometimes when a 10.4.10 image is restored, the dock icons get messed up (they point to random resources) and some applications do not start properly the first time (Photoshop CS3 gave me an "internal error"). Some other users have reported the pref icons and other links are also broken.

The proposed resolution to these problems was to rebuild the LaunchServices database by executing this command in Terminal.app:

/System/Library/Frameworks/ApplicationServices.framework/\
Frameworks/LaunchServices.framework/Support/lsregister \
-kill -r -domain local -domain system -domain user

Unfortunately this does not fix the problem. For a while I thought it did, but a few hours after restoring my MacBook Pro image, my dock went all screwy again, even enough I had reset LaunchServices as soon as my restored MBP booted for the first time.

To make sure I hadn't messed up, I restored my MacBook Pro yet again and reset my LaunchServices database. This time it only took a couple of hours for things to start misbehaving like before.

I'm running fully-patched 10.4.10 on a latest-generation Santa Rosa MacBook Pro, if that matters. Also, my backup drive image was initially called "Macintosh HD Backup", though I tried renaming it back to "Macintosh HD" before restoring so both drives are named the same, which seemed to make no difference.

Can anyone tell me what I have to do to make my restored 10.4.10 images behave? Restoring dock icons isn't a big deal, but some applications like Photoshop CS3 are not starting properly the first time, and who knows what else has been damaged because of this issue? And restoring the LaunchServices database is not making this problem go away.

Fortunately I'm only doing this to get familiar with SD!, so no data has been endangered, but I'm glad I decided to experiment with restoring before I truly needed it, as it doesn't quite seem to be working.

I should also stress that I have never seen this bug on any of my 10.4.10 Macs prior to restoring with SD!.

dnanian
10-01-2007, 01:07 PM
This is definitely not something we've seen in house. The users that have reported this have been able to fix it with LaunchServices (which also might be messed up on the source).

As far as things misbehaving "a couple of hours" after restoring -- apps that started working stopped working a few hours later?

Photoshop CS3 might have issues because it's copy protected. It may have detected that it's no longer on the original Mac, and is throwing a weird error to encourage you to call support. Are there any errors in the system.log (use Console) when this occurs?

Finally: are the drives you restored to named the same as the source was?

Derekasaurus
10-01-2007, 02:29 PM
To answer your questions:

1) As far as my dock misbehaving "a couple of hours" after restoring, I'm referring to my dock icons suddenly pointing to wrong targets or their icons turning into blank documents when I click them. For example my DVD Player dock icon worked just fine for a while after restoring, but when I clicked it a few hours later it suddenly opened some random system folder instead of launching the DVD Player. It worked for a while, then stopped working.

2) Photoshop CS3 had an "internal error" the first time I launched it, but then it started just fine the second time. This error happened after the first time I restored, but not the second, so this is not a repeatable problem. The next time it happens I'll see what's going on in system.log. It hasn't happened on the current image of my restored system--only dock icons and links are getting screwed up--so my current system.log does not have this information.

3) Unfortunately the first time I cloned my MBP I named the external drive "Macintosh HD Backup", which is not the same as "Macintosh HD", the default name of the source drive I'm cloning. Since then I renamed my clone to "Macintosh HD" so it matches the original, but the clone was booted once as "Macintosh HD Backup", which sounds like it might be a bad thing.

It seems that to eliminate some possible errors I should rebuild my MBP from scratch (i.e., clean OS X installation) and clone it to an external HDD with the same name as the original (i.e., "Macintosh HD"). Then I'll restore from the clone, reset the LaunchServices database, and use the system to see if the problem resurfaces.

I'll post again if I can't get rid of the problem. I really want to get to the bottom of this before I have to recover for real in an emergency.

Incidentally, in a related post you suggested excluding /Library/Caches/com.apple.LaunchServices.* to another poster. Should I be doing this as well?

dnanian
10-01-2007, 02:57 PM
I honestly don't know why your dock icon would work just fine for a while and then stop working. At that point, we're out of the picture, so perhaps it's something else you're running or ran?

Certainly, naming the new drive the same as the old is a good idea, since aliases will then resolve to the "right" drive.

No need to exclude the LaunchServices cache: it's mostly already done for you (there are two, we exclude the primary, and it didn't help that user -- again, we can't reproduce this in house, so it's a matter of trying to determine what it is about your system that's different).

maccer
10-05-2007, 01:01 PM
I've experienced this very same problem. I don't know if the dock icons misbehaved after "a couple of hours" or it's merely that I didn't notice they were misbehaving until I clicked on them, but some of them certainly pointed towards random documents.

What I did notice immediately after the restore is the Apple menu items (About This Mac, Software Update..., System Preferences) all pointed to random files. For example, Choosing "About This Mac" would open the "About This Mac" window fine, but clicking on "More Info..." would attempt (and fail) to open an obscure jpg buried in an application package. To correct this I deleted the jpg, clicked on "More Info..." and after it linked correctly I restored the deleted file.

I restored my OS X volume a more than a week ago and I'm still finding incorrect links. Just today I clicked on the "Address Book" icon in the dock and it launched a random unix file in the Terminal window. Not good.

dnanian
10-05-2007, 01:03 PM
Hi, Maccer -- did you rebuild your launch services database?

maccer
10-05-2007, 01:08 PM
dnanian,
No. I'm not certain what a launch services database is or how to rebuild it. However, like Derekasaurus I had the disk image I restored from named "OS X Backup" rather than "OS X" which is the name of the source. Any help?

dnanian
10-05-2007, 01:18 PM
It's easy to rebuild -- use Onyx or Cocktail (see VersionTracker).

It's the drive you restored to that's of interest -- it should be named the same as the original drive.

maccer
10-05-2007, 01:50 PM
Okay, I ran "Cocktail" and rebuilt the launch services database. Then I clicked on a few dock icons. Most worked fine. When I click on the icon for my printer utility app I got an error message that there was no application assigned to open the document "info.nib."

The drive I restored to is named the same as the original.

dnanian
10-05-2007, 01:58 PM
For some reason, your printer icon's alias isn't resolving properly, so drag that off and back on from the original location.

maccer
10-05-2007, 02:04 PM
Absolutely! That's how I've been fixing this problem since the restore. This is the 4th dock icon I've found that I've had to drag off and replace.

dnanian
10-05-2007, 02:08 PM
Apple has clearly made some changes in the way they resolve aliases or manage the Dock in 10.4.10. We're copying the files as they exist on disk faithfully. But something in OSX's been broken (no doubt as the result of something that was fixed) that seems to be affecting Launch Services and some aliases, on some Macs.

We're looking for a simple case that we can reproduce and send to Apple (if they don't already know about the problem, as they very well might), but we haven't been able to find one yet (I can't reproduce the issue in-house, and it affects a pretty small percentage of people). Sorry for the frustration in the meantime -- I'm hoping Apple's found and fixed it in the rumored 10.4.11...

maccer
10-05-2007, 02:17 PM
So basically it's c'est la vie for now?

dnanian
10-05-2007, 02:21 PM
Unfortunately, I don't have a workaround except for LaunchServices, or to roll back to 10.4.9 until Apple resolves the issue...

maccer
10-05-2007, 05:25 PM
Too bad, huh? Well, thanks for the info and quick reply. I truly appreciate it.

dnanian
10-05-2007, 05:30 PM
These kinds of things can be very frustrating for you and us, believe me. :(