PDA

View Full Version : Automated Execution


zack
03-27-2005, 11:18 PM
I restored my backup from my fw drive. Everything seems to be ok. But when the automated backup script is run, it halts at "Choose Application:" dialog with "Where is SuperDuper.app".

Even though I give the right path, during every automated backup it halts at the same dialog requiring manual intervention

dnanian
03-27-2005, 11:24 PM
That's strange, zack. Did you name the source and destination the same?

I think you can probably resolve this by rebuilding the Launch Services database. Use the following command:

/System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

zack
03-27-2005, 11:35 PM
Tried that, I get the same error

zack
03-27-2005, 11:41 PM
Hey it works! Thanks!

I have absolutely no idea what that script does, but I just ran it and it works!

[I'm a recent switcher who is still learning the ropes in this world]

dnanian
03-27-2005, 11:47 PM
That command rebuilds an internal OSX database that contains the location of various applications and the like. Glad it worked!