PDA

View Full Version : Sharing XCode Developer Folder


john love
07-23-2007, 03:26 PM
Dave -

Just downloaded and installed XCode's Developer Folder at root level.

Updated my Shared Users and Apps Clone, adding the folder "Developer" as shared. SuperDuper came to a screeching halt after copying/sharing everything else (happened twice). This is to say, the blue "Copy" bar math info stopped advancing, but the clock kept on ticking.

Changed "Developer" to "ignore" and everything happened OK, then simply added a symbolic link aka "alias" to the clone at the root level.

What's happening here?

Thanks, Dave, in advance.

John Love

dnanian
07-23-2007, 03:32 PM
It was probably copying a large file, John...

john love
07-23-2007, 07:49 PM
The reason I say that is that the regular cloning with ignore "Developer" takes about the usual 8 minutes.

With sharing "Developer" the time escalated to up to 15+minutes before I aborted .. if all sharing does is to create a symbolic link or alias and place it on the clone, that should not take an additional 7 minutes.

I wonder if the problem centers on the fact that "Developer" is at the root level of the drive.

Also, I've come across one or two other posts about inordinate delays while creating a clone .. one talked about Parallels which I don't have because I'm still working with a PowerPC, System 10..4.10 and the other talked about waiting for hours with no finishing creating the clone. You responded with words to the effect of doing some other things while cloning .. the only thing I remember doing is cmd-i for Get Info on the clone to see about the size.

Anyway, just some thoughts.

dnanian
07-23-2007, 08:25 PM
Sorry, I misunderstood what you said. It's still going to scan the folder, and if I had to guess the script wasn't constructed properly, and thus was copying -- not sharing -- the folder. But I'd have to see the log to know for sure... perhaps you should send that in to me @ support.

john love
07-24-2007, 12:40 PM
namely, "if I had to guess the script wasn't constructed properly" .. so, I reconstructed the script almost from scratch, taking care to put my special copy first, followed by all the sharing stuff in alphabetical order.

Everything worked like a charm. I do not have the slightest clue if the above ordering is technically required, but that's what I did anyhow and it worked.

Thanks for being there for all of us.

John Love

dnanian
07-24-2007, 12:41 PM
Glad you were able to get it going, John... :)