PDA

View Full Version : Problem with 10.4.10


carillon
07-18-2007, 10:07 PM
Today I made a clone of a 10.4.10 machine and then cloned it to a different Mac. Everything appeared to go as planned however one of my Java apps would not run because of the following message:

A script error -1728 occured: Can't get <<class fcrt>> of every <<class pcap>> of application "Finder".

Nothing I tried corrected the problem including running fsck, repair permissions and even re-installing the 10.4.10 combo updater.

Finally I ran Onyx and I ran the Reset for the Launch Services database maintenance command and that seemed to fix it.

Anyone else have an issue like this?

dnanian
07-18-2007, 10:09 PM
We've seen this quite a bit with 10.4.10, regardless of whether or not the system has been copied with SD... resetting LaunchServices fixes it every time.

carillon
07-18-2007, 10:32 PM
Has this been reported on any of the Mac admin sites?

dnanian
07-18-2007, 10:36 PM
I have no idea, sorry.

carillon
07-19-2007, 08:36 AM
Neither one of these two Macs were having the issue before they were imaged. The problem only occured after I had made the backup and copied the image to a different Mac.

So, it seems logical that SD did have something to do with the problem happening.

I'm doing a third Mac the same way right now, we'll see how it does.

Thanks

dnanian
07-19-2007, 10:02 AM
We don't make changes to the source, so I can't see how SD! could change these things.