PDA

View Full Version : SD taking *extremely* long when FileVault volumes are present


jrychter
06-25-2007, 11:02 AM
I think it is time for SuperDuper to handle FileVault-encrypted volumes specially.

I've just ran SD and got: "Elapsed time: 1:33:09". That is for a backup of a 120GB HDD to a 80GB external drive. 20GB of this data is a FileVault sparseimage (my home directory).

From what I noticed, SD seems to do the following:
1. Read the sparseimage from the external drive to compare and see if an update needs to be done
2. Write the sparseimage with new changes
3. (that one I can't understand) rewrite the sparseimage AGAIN

I have no idea why it would do #3 above but I clearly saw it while repeatedly listing the directory where the sparseimage sits on the external HDD.

These backup times make SD almost useless.

My suggestion would be to implement a config option letting me specify which files are to be copied unconditionally -- bypassing the "smart" mechanism. In my case, I know that I want to copy the full sparseimage on every backup -- doing comparisons on it is just too expensive.

Hoping for a fix...

--J.

dnanian
06-25-2007, 11:27 AM
It doesn't do it twice, actually: it just writes it one time. "Smart Update" only checks the metadata, it doesn't check the contents.

jrychter
07-03-2007, 09:40 AM
Hmm, that's strange. I was pretty sure that at least the write operation took place TWICE. The backup time of 1h30 instead of the normal ~35 minutes would also indicate that.

I'm glad SD doesn't read the file -- it wouldn't make sense.

Does the amount of free space on the drive I'm backing up to have anything to do with how SD performs the backup, then?

--J.

dnanian
07-03-2007, 09:42 AM
It doesn't change the order of things at all, no, but it can affect the system, of course.