PDA

View Full Version : Can't Select Source/Destination in Disk Utility


Agentflit
05-17-2007, 03:25 AM
Hi,

I have a macbook with a recently replaced hard drive, and I have a sparseimage backup of my files on an external (nonbootable) drive. When I boot from the OS X DVD (10.4.6), I'm able to open and mount the backup but I can't drag anything to the source or destination boxes. Holding down the mouse button only allows me to multi-select from the list, and ctrl-clicking any of the drives doesn't offer a "source" or "destination" option.

Help? Thanks.

dnanian
05-17-2007, 08:42 AM
Please see this post (http://www.shirt-pocket.com/blog/index.php/comments/intel_mac_dvd_disk_utility_problems/) at the Shirt Pocket Watch (http://www.shirt-pocket.com/blog) blog.

Agentflit
05-17-2007, 10:20 AM
Hm, that's quite a bug. I'll give it a shot in the terminal tommorow since that looks like my only option (I don't have any other disk to boot from).

Thanks!

dnanian
05-17-2007, 11:35 AM
It is quite a bug, agreed. I believe Apple fixed it in their latest discs shipped with Intel Macs...

ReddSmith
05-17-2007, 12:36 PM
Purchased a Mac mini last month direct from Apple. The install disc is for OS version 10.4.7. Source and destination are uncooperative, as described above. Wonder if they'd send an updated replacement set?

dnanian
05-17-2007, 12:47 PM
You could try... another option would be to use something like Das Boot to create a bootable CD with Disk Utility on it...

ReddSmith
05-17-2007, 07:17 PM
Called Apple Support about this. I talked with "Jamie" for a half hour, mostly on hold while she researched this issue. Her answer was that I can't use DU Restore from the install disc to create a clone, and that third-party software like Carbon Copy Cloner (Blasphemy!) should be used. I wanted more details and she forwarded my call to a "specialist". The specialist wanted to know why I desired to run DU from the install disc, rather than from the running system. (I agree this can be done, I have done it successfully, as far as I can determine.) Then he, too, needed to research and consult about this issue, while I remained on hold for another half hour. His verdict was that, if the source and destination fields cannot be filled-in, effectively disabling the Restore function, then it is intentional, and not a bug. He had no explanation as to why this would be so, but suggested the software engineers must certainly have a reason. I said I believed this function worked in the past, but then he called me on this and asked for the install disc OS version (such as 10.3.x) which worked, and I couldn't tell him. He also posited that DU would be the same on all Tiger versions (10.4.x), so a newer disc set wouldn't make any difference.

Bottom line - I'm not getting updated discs because my old ones are apparently just fine...ha ha.

dnanian
05-17-2007, 07:46 PM
That's a truly ridiculous response, since it's pretty clearly a bug, and was fixed later. And to say you can't use DU Restore from the install disc is, well, also totally wrong.

Kind of sad that they provided those "answers".

Nicolinux
06-13-2007, 06:59 PM
Hi, just wanted to say that this bug also hits the tiger dvd's shiped with the first revision macbook.
Sadly there is another show stopper. I can't even choose an sparse image that's just plainly sitting on a usb drive or on another partition :(
So no restore options for me now, except installing another tiger system first.

dnanian
06-14-2007, 03:51 AM
There are workarounds in the blog post, Nicolinux.

Nicolinux
06-26-2007, 07:33 PM
Well, yes kind of. First in involves reinstalling Mac OS and second it relies on an external harddisk (that I don't own). So only the asr utility remains.

Just an idea. Wouldn't it work to make a bootable copy of the stock tiger dvd and replace only the diskutility app? I tried creating a master image and swapped the diskutility app but I haven't found a possibility how to burn the image so that it remains bootable.

dnanian
06-26-2007, 07:38 PM
No, no -- you can use Terminal on the disc with asr, which isn't too bad. You can't make a bootable disc of Tiger without using Das Boot or something...

summanulla
07-16-2007, 07:47 PM
I ran into this bug today while upgrading my MacBook to a larger HD. I had two different image backups available on network or firewire drives, but no bootable partition. I was contemplating the terminal option and not sure how to reference the image stored on the firewire drive. But then I realized that I was going to partition the internal HD for bootcamp use anyway, and I could just make a 2nd bootable partition on the new empty internal drive.

I partitioned the internal drive the way I would have for bootcamp, and then installed (onto the extra partition) the most minimal Tiger I could from the DVD (skipping the DVD verify step, this only took about 10 or 15 min). Booting off that partition let me use the Disk Utility according to the manual's fine directions. Although I was sure I could eventually figure out the terminal instructions, this was easier by far for me. I'm now contemplating whether I can spare the space for an emergency os x boot partition on the internal drive...

dnanian
07-16-2007, 07:50 PM
You could also use DasBoot to make a bootable device...

summanulla
07-16-2007, 11:43 PM
Well I got ahead of myself. Yes, it was an easy way to restore from the image I had on the firewire drive. But by partitioning the drive in Disk Utility, I now can't run Boot Camp Assistant, which seems to require the startup disk be a single partition. Which I now recall reading about months ago, but had forgotten until it's too late. I will have to mull this one over tonight... Tomorrow I'll take a look at Das Boot.