PDA

View Full Version : HELP!! Automated Backup...


n1sni
03-25-2007, 11:16 PM
Hello,
I am using the newest version of SuperDuper on a MAC and am running into problem I just can't figure out! We are backing up to a Windows 2000 server, and it will only work if a manually mount the drive. I have set up a scheduled task and it fails every time when trying to mount the drive. So I created an AppleScript to mount the drive (Also added it to Startup apps - but doesn't work well since this user always uses sleep, and the drive seems to magically disappear by itself <ARGH>), and I have to have the user run that before the backup starts. I would have assumed that the "Run Script" function would have run the script before it tried mounting any drives (Which fail if the Windows Share is not mounted already <ARGH>), but it does not.

Am I missing something here?! Please tell me I am, I have been unable to give the customer a reliable backup solution for some time now (We have bought 6 licenses for the product, and I can't get any of them to backup consistently - Although the others do better because they are not mobile like this user).

Thank you for your time...

Bill Bushong

dnanian
03-25-2007, 11:25 PM
Bill --

We resolve a standard alias to get the network volume to mount, and it should work properly.

What you can do in this case, is navigate to Library/Application Support/SuperDuper!/Scheduled Copies off the User's home folder. Edit the "Copy Job.applescript" and add your mounting commands into the "before" section at the top.

Save the script, then open SuperDuper! and look in the Scheduled Copies window. Edit the entry that you just changed, then uncheck and re-check the checkbox. Accept that, and the script will run automatically -- that should work for your user.

n1sni
03-25-2007, 11:28 PM
Ok... that was fast :) I will try it out, and let you know... THANK YOU!

bvooste
05-31-2007, 12:25 PM
I'm having the same problem getting the Samba volume to mount before the sparseimage is accessed. I read the suggestion below to

"navigate to Library/Application Support/SuperDuper!/Scheduled Copies off the User's home folder. Edit the "Copy Job.applescript" and add your mounting commands into the "before" section at the top."

But there is no "Copy Job.applescript" in said folder. There is only an sdsp file that I can't edit with the AppleScript editor nor with the text editor.

Please advise, thanks!


Bill --

We resolve a standard alias to get the network volume to mount, and it should work properly.

What you can do in this case, is navigate to Library/Application Support/SuperDuper!/Scheduled Copies off the User's home folder. Edit the "Copy Job.applescript" and add your mounting commands into the "before" section at the top.

Save the script, then open SuperDuper! and look in the Scheduled Copies window. Edit the entry that you just changed, then uncheck and re-check the checkbox. Accept that, and the script will run automatically -- that should work for your user.

dnanian
05-31-2007, 12:38 PM
It's not actually in Scheduled Copies, but inside the settings in scheduled copies. You have to Control-click on the scheduled copy, then choose "Show Package Contents" and you'll find the script in there.