PDA

View Full Version : Disable Spotlight on target volume?


rjackal
02-10-2007, 10:42 AM
Hello:

I would like to disable Spotlight from indexing my target volume.
I did read the post in the FAQ forum here that says to drag the volume to the Privacy list in Spotlight preferences, however, that doesn't work for me! :confused: When I drag it to the list, it doesn't show up in the list. I have Tiger 10.4.8. This is a USB2.0 external drive on an Intel MacBook Pro mounted as HFS+

Should I try the 'disable' script given in that thread?

I have also been reading about this issue here:
http://www.thexlab.com/faqs/stopspotlightindex.html

I have tried rebooting in Safe mode, performing a SuperDuper backup, and then attempting to disable indexing of the target via the command line, specifically: sudo defaults write /path_to_volume/.Spotlight-V100/_IndexPolicy Policy -int 3 and that didn't work either, I got an error about unrecognized parameter or something.

Any further thoughts on this? Thank you!

dnanian
02-10-2007, 04:39 PM
I'd actually suggest using Disk Utility to erase the target volume. Restart, then add it to Privacy. That should do it!

rjackal
02-11-2007, 08:40 AM
That worked, thank you!