PDA

View Full Version : Spotlight privacy pane not working


aljoscha
12-20-2006, 08:31 PM
I am aware this is not really SDs fault. Anyway, the recommended way to disable the spotlight indexing of the backup seems to be to just move the drive to the Spotlight privacy pane.
But it never shows up there, even though the green plus apears on dragging it over the pane.
Instead I get the message

2006-12-21 01:22:40.647 System Preferences[2481] Error: _MDSetExclusion returned -1

in on console. Has anyone else seen this?
The indexed backup is really annoying, especially since LaunchServices show all programs twice, even if the external FW drive is not attached anymore!

I have a LaCie 200MB external FW drive, the backup partition is formatted using journaled HFS+.

dnanian
12-20-2006, 08:40 PM
The easiest way to fix this is to use Disk Utility to erase the volume: that'll allow it to be added into Spotlight's Privacy tab. But Privacy isn't why you're getting programs twice: to fix that, you should use Onyx (or its equivalent) to rebuild your LaunchServices cache.

Hope that helps!

aljoscha
12-23-2006, 01:49 PM
So you say, erasing the volume and adding it and then backing up onto it will work. I could swear I already tried that and the Backup just vanished from the privacy pane.

I don't understand the thing about Privacy not beeing the cause for my double entries for all Applications in LaunchServices.

As I understand it, its the result of spotlight finding each application twice: once on the original disk and once on the Backup.
So whenever I clean up my LaunchServices DB (I use MainMenu for that) and run SuperDuper, my Backup gets indexed and the Apps appear doubled again.
Thats what I am experiencing.

Thanks a lot for your help!

Alex

dnanian
12-23-2006, 02:25 PM
Spotlight is unrelated to LaunchServices: they're entirely different things... I don't know what to say other than that...