View Full Version : Disabling Spotlight?

12-18-2006, 01:03 PM
I was recommended by a friend to try out SuperDupe but when I do a backup it works on and on for a few hours, then suddenly stops with a couple of hundred files left to evaluate and some more to copy. I ran dmesg in the terminal and it says "fs_events: add_event: event queue is full! dropping events." in a lot of lines. I found this link http://www.nabble.com/Event-in-dmesg-question-t2563691.html through google, and it seems like it is Spotlight that stops my backup.

After dmesg the whole mac froze and I had to force-reboot it. This has happened before, which is why I want SD to backup the disk so I can reinstall OS X. Maybe the problem has always been Spotlight, I haven't been able to isolate the crashings and understand why they come and go.

Now I would like to try to backup again. When trying yesterday night it also stopped after about 12gb being copied. I didn't investigate dmesg that time, but I guess it was Spotlights fault.

So: do you know how I disable Spotlight? I found a link http://www.sweetwater.com/expert-center/techtips/d--07/12/2006 but it seems a little to dangerous. Would it be enough to add /Volumes to the Spotlight list of places not to index?

Have you heard of anyone else having this problem?

12-18-2006, 01:16 PM
No, haven't really heard of this. But you can add the destination volume to the Spotlight Preference Pane's "Privacy" tab: that should help.

12-18-2006, 09:20 PM
On the fifth or sixth trial it finally worked. I would like to share this in case of anyone having the same problems as I had.

I was trying to backup my Powerbook disk onto a disk image on my external FW drive. The problem was that after evaluating/copying about 12-13 gb of the files to the disk image, first SD and then the whole computer would freeze (although mouse pointer would move). "cat /var/log/system.log" told me a lot of lines of "fs_events: add_event: event queue is full! dropping events.".

The error message seemed (http://www.nabble.com/Event-in-dmesg-question-t2563691.html) to come from a collision with Spotlight, so I disabled (http://www.sweetwater.com/expert-center/techtips/d--07/12/2006) it.

Still, the backup would fail. I found a comment (http://www.macosxhints.com/article.php?story=2003101415481414) (scroll down to "Tiger is effected as well!" by "ktohg", Tue, Aug 9 '05 at 4:39PM PDT) and followed it, even though my problems weren't exactly the same:
sudo mv /Library/Caches /_Library_Caches
sudo reboot

And now I also chose "Repair permissions on Mac OS X" under Options, which I hadn't dared to touch after the Spotlight disabling, because of the last line "This can be reversed by repairing permissions. (http://www.sweetwater.com/expert-center/techtips/d--07/12/2006)".

And suddenly the backup worked. I do not now if it was the Spotlight disabling (and then repairing permissions), or the /Library/Caches moving, or a combination of them, but somewhere in there is the solution. What I _do_ know is that it can't be the single "Repair permissions", because I was doing that on all trials until I disabled Spotlight.

Anyway, I hope this will help someone. And thanks for a great software! I'll use my Christmas money to register first thing in Januar; I would like to be able to use Smart Update as my primary backup plan after reinstalling OS X.