PDA

View Full Version : Restoring files or folders


Furpurse
12-13-2006, 08:18 AM
Hi all,

This may be a simple question but im fairly new to all this, so please bare with me :)
I use SD to backup network user accounts on an xserve from one 400gb drive to another 400gb drive.
If I want to restore individual files or folders I have to log into the xserve as root so I can access both drives and then drag the files from the backup to the main drive.
However after doing this the files lose their original ownership rights, and become the root users.

Am I missing something? If I login as admin, I cant get to the individual files so it has to be root doesn't it?

Thanks for any help :)

dnanian
12-13-2006, 10:29 AM
No, ownership should copy when you copy things. You can also use other commands (like cp) that will preserve...

Furpurse
12-14-2006, 12:26 PM
Thanks for the reply.

It definitely doesnt copy over. It becomes owned by the system. Ive tried just dragging the files over and also copy and paste. I'm not confident enough to use Terminal.

I've only just started doing a smart backup so maybe it has to do with that?
I used to do a delete and copy and I'm sure I never had any problems then.

Any more idea's

Thanks

dnanian
12-14-2006, 12:44 PM
No, it wouldn't have anything to do with Smart Update -- the files are, after all, proper on the backup.

I'm a bit surprised that Finder is changing the ownership of the original files (since there's no reason to do that); have you tried using PathFinder, perhaps?

And just to verify -- you didn't turn ownership off on the backup, did you? That would cause this kind of trouble.

Furpurse
12-18-2006, 07:00 AM
Where would I turn the ownership off? In SD? I have "Copy ACL's" ticked in the options.

Is Pathfinder an application I can download?

Sorry, I did warn you I was a novice :o

dnanian
12-18-2006, 11:27 AM
Ownership is done in the Get Info panel for the volume.

PathFinder is a program that you can get from http://www.cocoatech.com.

Furpurse
12-21-2006, 07:06 AM
Checked the ownership and its exactly the same. In fact every setting for the 1st drive is identical on the second.
Tried another copy last night, logged in as root this morning and copied files over, but they became owned by the system again.

If I restore the drive as a whole its fine. Its just a pain when a student wants to restore a single file.

dnanian
12-21-2006, 10:48 AM
OK. As I said, I'm a bit surprised that the system is changing the file ownership, but I think you're going to have to use Terminal to do this. It's easy to do. Just open Terminal, type:

cp -p

with a space after the p. Then, drag in the file you want to restore, and terminal will type its whole path for you. Type a space after that, and then drag in the folder you want to restore it to. Press Return at the end, and you're done!

Furpurse
01-08-2007, 01:05 PM
That did it. Great stuff.

Thanks dnanian :)

dnanian
01-08-2007, 01:10 PM
Terrific. Glad I could help.