PDA

View Full Version : Unexpected Quit cloning to Mac Pro


MacDorq
10-09-2006, 07:58 PM
I keep getting an "Unexpected Quit" when cloning a master OSX 10.4.8 (Intel) system to a new 3 Ghz Dual Core Mac Pro. It has happened on two different machines. Never had a problem cloning the same system to dozens of Intel MacBooks.

The problem seems to happen at about 550MB into the cloning process.

Any thoughts as to why this may be happening? I checked off the ACL option as noted in a prior thread but it made no difference.

Thanks!!

Here is an excerpt fromt he crash log. I can post the entire thing if it would help.

OS Version: 10.4.8 (Build 8L2127)
Report Version: 4

Command: SuperDuper!
Path: /Applications/SuperDuper!.app/Contents/MacOS/SuperDuper!
Parent: WindowServer [55]

Version: 2.1.3 (80)
Build Version: 2
Project Name: SuperDuper!
Source Version: 573

PID: 187
Thread: 2

Exception: EXC_BAD_INSTRUCTION (0x0002)
Code[0]: 0x0000000d
Code[1]: 0x00009afc

Thread 2 Crashed:
0 libSystem.B.dylib 0x9000101f pthread_mutex_lock + 168
1 com.apple.AppKit 0x932967bb -[NSFocusStack popTopView] + 62
2 com.apple.AppKit 0x932965f5 -[NSView unlockFocus] + 110
3 com.apple.AppKit 0x933dc280 -[NSUIHeartBeat unlockFocusInRect:] + 646
4 com.apple.AppKit 0x93420367 -[NSProgressIndicator heartBeat:] + 1452
5 com.apple.AppKit 0x93326572 -[NSUIHeartBeat _heartBeatThread:] + 1147
6 com.apple.Foundation 0x925f536c forkThreadForFunction + 123
7 libSystem.B.dylib 0x90023d87 _pthread_body + 84

dnanian
10-09-2006, 08:07 PM
We've seen a number of crashes similar to this in 10.4.8, which seems to be an OSX issue. We've reported it to Apple along with a number of examples from SD! and other applications (it's not SD specific)...

flybaby6p2
11-23-2006, 08:29 PM
i have had similar experience... while trying to backup my mac book pro.
and while searching for any info about this on google, my safari crashed
with similar error message... crashed thread was executing 'pthread_mutex_lock' function...

believe it or not while i was filling out crash report for the crashed safary,
my crash reported crashed! the 'crashed' thread of the crash reported was executing same 'pthread_mutex_lock'!

i am not sure if this has anything to do with it but about 6 hours before this
problem started occuring i upgraded my firmware to EFI Firmware Update 1.2 ( MBP11.0055.B08 )

i still managed to backup my system by creating new account with admin rights... and backing up my drive using that account.

dnanian
11-23-2006, 10:14 PM
Yep, there you go. This is the same bug in OSX biting Safari, too. I'm pretty sure it has nothing to do with the EFI update, though...

dnanian
11-25-2006, 10:08 AM
Yeah, you'll really see this bug turn up in a lot of applications, unfortunately. Quite annoying...

eq2675
11-27-2006, 06:49 PM
I've had the exact same problem with my Mac Mini running 10.4.8 with all the updates including EFI. No problems at all with SuperDuper! until just recently.

I think I may have fixed it by doing all the maintenance and cleaning options available in OnyX

http://www.titanium.free.fr/pgs2/english/onyx.html

Time will tell.

dnanian
11-27-2006, 06:57 PM
Seems unlikely -- the intermittent nature of the problem lends itself to "voodoo" fixes. Given what I know about what's happening, Onyx shouldn't have any effect.

(Note that hiding or minimizing SD! during the backup should, though.)

eq2675
11-27-2006, 11:18 PM
Seems unlikely -- the intermittent nature of the problem lends itself to "voodoo" fixes. Given what I know about what's happening, Onyx shouldn't have any effect.

(Note that hiding or minimizing SD! during the backup should, though.)

FWIW, I checked system and kernel caches (among many other normally non- checked items) in OnyX when performing the cleanup.

dnanian
11-28-2006, 12:47 PM
OK. Well -- anyone else out there who this is happening to: care to give it a try?