PDA

View Full Version : I/O exception(5) - *very* slow/incomplete bkup


hickey
09-08-2006, 09:02 PM
hi there,
i am trying to use SD for the first time and i am encountering an issue i can not find an answer to in the troubleshooting section of the user guiide nor in this forum.

I am trying to backup for the first time my powerbook g4 running 10.4.7 to a maxtor onetouch II 250gb drive via fw, which is formatted as ms fat32. I have SD Version 2.1.3. So i am using the sparse disk image, having tried both the option in SD and to create one manually before hand with diskutility but encouter the same issue.

SD will back up ~3 to 4gb in 10s of minutes and then it doesn't increase, just keeps trying to go. i have tried multiple times leaving it for upto 10hrs at most so far, with it not going past ~4gb. the log shows repeatidly the following warnings for lots and lots of files.

| 05:56:50 AM | Info | Attempting to copy file using copyfile().
| 06:00:29 AM | Info | Attempting to copy file using ditto.
| 06:00:30 AM | Info | Successfully copied file.
| 06:02:18 AM | Info | WARNING: Caught I/O exception(5): Input/output error
| 06:02:18 AM | Info | WARNING: Source: /Users/gabs/Documents/temp/iPhoto Library/2005/04/08/Originals/IMG_0660_1_1.JPG, lstat(): 0

i have run the *repair* option on both the external hdd and the internal hdd, it picked up some errors on the internal which it fixed.

i am actaully having some logic board issues where one of the ram dimms is not being recognised so the g4 is only running with 1gb now, instead of 2gb. i actually want to back it up so i can take it to the apple repair centre and get the logic board replaced, as this is a known issue.

i have checked what else is running and the cpu isn't being heavily utilised, and there doesn't appear to be any other processs trying to monopolise the cpu.

is it this hw problem that is causing SD to not work?
is there something i can do to get SD to bkup?

all your help is greatly appreciated, thanks.

BTW - can anyone tell me where the SD log file is stroed on int he file structure? i saw this in another post and can not find it now. Thanks.

dnanian
09-09-2006, 10:24 AM
The problem -- as documented in the User's Guide -- is that you cannot store an image on a FAT32 volume. FAT32 has a 4GB file size limit, which is why you're seeing it go to 4GB quickly... and then it gets stuck as it tries to copy files, the system fails to extend the image, etc.

So, the way you want to handle this is to either format the external as HFS+ (Mac OS Extended) and write directly to it, or partition it into an HFS+ volume and a FAT32 volume and write to the HFS+ side...

(The logs are inside the settings package. If you open the log (Cmd+L) and then Cmd-click the title bar, it'll show you the full path, and you can select the "Logs" folder there to open it in the Finder.)

hickey
09-09-2006, 12:11 PM
Thanks Dave.
Sorry for not finding this the first time in the user guide, i have spotted it now.

Does anyone have any suggestions on tools to be able to resize partitions? ...DiskStudio?

Thanks, ben

dnanian
09-09-2006, 12:15 PM
I've used iPartition successfully, and I'm sure there are other solutions (the SubRosaSoft people have been here before suggesting their product).