PDA

View Full Version : Gone iTunes alt white/grey lines & retrieving itunes APP from backup?


greenjeens
07-26-2006, 12:32 AM
First problem is the alternating white and grey horizontal lines that show each song track info. The purpose of the lines is to help read long horizontal lines of song info, without confusing them for the info above or below...well those lines dissapeared and now it's just black letters on a white background. I played with the monitor settings and that's not the problem. Someone advised reinstalling the iTunes application.

Luckily, I have another copy of my complete library on the backup partition/drive that shows the white/grey lines, from a week ago.

I have re added applications, but I'm not sure exactly how to extract/copy just the iTunes application from the backup and transfer it to my main HD?

I think the difficulty is separating and manipulating just the itunes application without the database part, that's confusing.

I made an archive Zip of the backup itunes library, but it copied lots more info than just the application. I then put it in the shared user files and opened that itunes copy from the main HD page. Grey lines were still not there. I'm beginning to think it is some other setting/source that's making the alternating grey/white lines not show up. And suspect it will reoccur even with a new copy of the application?

I'm thinking about copying the backup to the main HD, but a little afraid. I will lose some songs and info that I have added in the last week, since the last update.

Is there a SIMPLE way to replace only the itunes with the backup copy?

Or, I may just do nothing since it doesn't seem to be that big a problem and I don't wish to goof up itunes or other stuff even more?

Thanks for any tips,
Dave

dnanian
07-26-2006, 09:12 AM
You can't really copy just iTunes itself, because it's not a drag-and-drop install. I'd re-download from Apple's site and install again.

greenjeens
07-26-2006, 04:46 PM
You can't really copy just iTunes itself, because it's not a drag-and-drop install. I'd re-download from Apple's site and install again.

OK got 6.0.5 from apple threw my itunes application away and then tossd the garbage. Made a copy and put it on another drive partition, just in case.

Went through download routine, yet the new downloader says "0 bytes to install" and the actual download page is greyed out and says "disabled". There's no itune app in my finder and i shut down the drives where I backed it up.

I've been hunting around for an answer, but I'm stumped, What's keeping a new itunes from getting downloaded? Could it be "Itunes Library manager", or a plist ?

dnanian
07-26-2006, 05:03 PM
Try deleting the iTunes receipt from /Library/Packages.

greenjeens
07-26-2006, 05:11 PM
Brilliant, thanks that worked! What a valuable lesson. I've downloaded multiple apps and never run into this before. Thank you very much..

Grey lines still aren't there:( I suspect there is something interacting with itunes that makes this reoccur.

Oh well, everything still works!

dnanian
07-26-2006, 05:13 PM
You might want to see if it's an account-based thing by creating a new user account and trying iTunes from there.