PDA

View Full Version : Cannot make a script


kajsa
07-13-2006, 04:51 PM
I have tried to make a script ignoring my picture folder when making a smart update.
I have followed the instruction in the Users guide but I get the following eror report:
| 09:06:08 PM | Error | sh: line 1: /Users/kajsa/Library/Application Support/SuperDuper!/Copy Scripts/Untitled 2.dset: Permission denied

In the Description box I wrote
All files on IMacHD will be copied to LaCie Disk, except for all usersīPicture folders and the temporary and system-specific files that Apple recommends excluding.
In the Includesd scripts I have choosen: Backup-all files.dset
In script Commands: Ignore Users/kajs/Pictures
Please tell me what is wrong!

dnanian
07-13-2006, 06:05 PM
This is because you're trying to use a copy script as a shell script in the Advanced tab.

Uncheck that option. Then, select your copy script in the 3rd pop-up in the main window. See the User's Guide for a description of how to do this, with lots of screen shots, etc...

Hope that helps!

kajsa
07-14-2006, 01:54 AM
I do not know the difference between a copy script and shell script. I have followed the Usersīguide on page 20-24 where they talk about copy scripts.
What option shall I uncheck? Something in Description or Included scripts or Script Command?

dnanian
07-14-2006, 09:07 AM
A copy script is what you have. A "shell script" is a way of talking to the Unix layer in OSX.

You've set your copy script in the Advanced tab of Options: open Options and click the Advanced tab and you'll see.

You want to select it in the 3rd pop-up in the main window instead.

kajsa
07-14-2006, 12:29 PM
At last I understood what to do! Now it works OK! Thank you very much for your reply!!

dnanian
07-14-2006, 12:44 PM
You bet, kajsa!