PDA

View Full Version : Disabling Spotlight (Privacy Controlpane doesn't work)


plessl
06-07-2006, 03:33 PM
I know, this is supposed to be a FAQ, but the hints in this forum didn't work.

How do I permanently disable Spotlight indexing for my backup made by SuperDuper! ?

When trying to add my backup Volume to the Privacy list in the Spotlight control pane, the Volume (/Volume/Backup) is not added, but simply ignored by the control pane.

Spotlight Indexing is currently enabled, see the following shell output:

sudo mdutil -s /Volumes/Backup/
/Volumes/Backup/:
Status: Indexing Enabled

I would be glad for any hint.

Best regards,
Christian

dnanian
06-07-2006, 04:21 PM
You want indexing to be enabled, actually, you just want the drive in privacy (which disables indexing a different way).

If you can't get it to add to the Privacy tab, it's likely that the .Spotlight_V100 folder, at the top of the drive, is corrupt.

Try removing this folder. Then, restart your Mac. Once restarted, add it to the Spotlight Privacy tab, and I think it'll work properly.

plessl
06-07-2006, 04:55 PM
Are you suggesting to remove the .Spotlight_V100 folder on my boot disk, or on my backup disk?

I did remove the folder on my backup disk (rm -rf /Volumes/Backup/.Spotlight_V100) and then did a restart.

But I still cannot add /Volumes/Backup to the Privacy tab. It seems, that it is still ignored. I did also reboot after trying to add it, but this didn't help either.

Do have any additional idea, what's going wrong?

Best regards,
Christian

dnanian
06-07-2006, 04:59 PM
On the backup disk. I'm quite surprised it won't let you add it to the Privacy tab. Why do you think it's ignored? Does it not appear in the list? (You can't judge by the mdutil command, because it will indicate that indexing is enabled.)

plessl
06-07-2006, 05:28 PM
Yes, if I try to add my backup volume to the privacy list, it simply doesn't appear in the list.

BTW: My backup disk has two partitions named Backup and Extended. If I add the other partition (Extended) to the list in the privacy tab, it gets added to the list as expected.

Do you think it makes sense to delete the /.Spotlight-V100 directory as well?

dnanian
06-07-2006, 05:39 PM
No, I don't think that'd make sense. Try booting into Single User Mode and deleting .Spotlight_V100 from there: that will hopefully fix it (since Spotlight won't be active).

Alternatively, you could try booting in Safe Boot, which will disable the indexing daemon, clean up the spotlight folder, then boot back and add to privacy.

plessl
06-07-2006, 06:56 PM
I followed your suggestion and did boot into single user mode, mounted my backup partition on the firewire disk, and deleted .Spotlight_V100.

But the situation didn't change. I still cannot add the partition to the privacy list.

dnanian
06-07-2006, 07:27 PM
I'm really at a loss: this is pretty basic functionality inside OSX. Perhaps you should contact Apple?

plessl
06-08-2006, 04:35 AM
I did one more experiment. Keep two backup sets, one at home and one at work.

I just tried to add my backup volume at work to the privacy tab and the same miss-behavior occured too. The backup disk has 3 partitions, I can add any partition to the privacy tab, except for the partition holding the backup made by SD.

egilDOTnet
06-08-2006, 04:41 AM
Have you tried disabling index'ing on the disk from the commandline instead? You do this using the mdutil tool as well. See this excellent writeup for more information: http://www.thexlab.com/faqs/stopspotlightindex.html

plessl
06-08-2006, 05:20 AM
I know about this website and it seems that I'm actually experiencing some sort of anomaly as described on the webpage. Some time ago, I tried to fix my problem by applying the hints on the page, but without any success.

It's unclear to me, what prevents the backup disk from beeing added to the Privacy pane.

BTW: Do you know, whether SuperDuper copying the .Spotlight_V100 folder from the source disk to the target partition?

dnanian
06-08-2006, 08:30 AM
We save and restore the important information from the .Spotlight_V100 folder. There's nothing about a SD! copy that would prevent Spotlight from working, but another alternative would be to use Disk Utility to erase the backup partition. Once that's done, add it to the Privacy tab, and we'll preserve that.

plessl
06-08-2006, 12:53 PM
Excellent! This tip worked!

I have deleted the backup partition with Diskutil and after that, adding the backup partition to the privacy tab worked as intended.

I will try later, whether this works also with my second backup disk at home.

dnanian
06-08-2006, 12:56 PM
Great, glad to hear it!

plessl
06-09-2006, 05:17 AM
The same trick also worked for my backup disk at home. Thanks for your help!

dnanian
06-09-2006, 10:08 AM
You're quite welcome.

nlaspf
12-26-2007, 01:03 AM
I know this is an old thread, but I had the exact same problem. Partitioned drive (Backup and Storage); I could add the Storage partition to the privacy pane perfectly, but the SD! Backup partition wouldn't work. I had to erase that partition with Disk Utility to make it work.

Just wanted to let you know. Maybe it's a SD! bug that can be fixed in the future or something :)

plessl
12-26-2007, 05:23 PM
I can confirm, that the suggested fix still works: You can add your backup volume to the Spotlight privacy pane immediately after formatting the disk with Diskutil (i.e. before SuperDuper is ran for the first time for this volume).

I don't know whether adding the backup volume later, i.e. after some backups have been made with SuperDuper, works now. But since there is such an easy workaround I don't consider this an important problem. You can easily reformat the volume later, add the volume to Spotlight privacy and make a backup after that.