PDA

View Full Version : Using Two Drives In Sequence


fredhoysted
03-27-2006, 08:55 AM
Hi,

I'm wondering what people would think of the following approach, and whether there are any special issues using SuperDuper! to manage it.

Currently, I back up to a single external firewire drive. But that doesn't address the risk of it being stolen along with my main computer or a house fire, for example. In both scenarios, the original data and the backup would be lost.

I am considering buying as second external firewire drive. I would then run my regular nightly backups to one of them for, say, a month. Then, I would unplus that first drive, store it offsite and swap in the second drive. At the end of the month, I'd swap them back again.

So, for situations where a hard drive has crashed, for example, I'd have a good, up-to-date backup. And in the worst case scenario, it would be a maximum of a month out of date.

Presumably, for SuperDuper! to handle this from a single script, all I would have to do is ensure the two drives had exactly the same volume name. Would this work? Are there any issues with it?

Many thanks,

Fred

dnanian
03-27-2006, 09:11 AM
No, that won't work, because we don't look at the volume name -- we look at the UUID. However, you can set both UUIDs to be the same to make this work.

NOTE: please, this is only for advanced users. Normal users shouldn't be doing this, so -- if you're a regular user, don't, OK?

For the advanced, though:

We have a little program called SDDiskTool that's inside the SuperDuper bundle you can use to set the UUID. It's in SuperDuper!.app/Contents/MacOS/SDDiskTool. You'd use:

SDDiskTool -g /Volumes/some-disk-name

to get the UUID. Then, to set it, you'd use:

sudo SDDiskTool -s the-UUID /Volume/some-other-disk-name

So, pick the one you want to be the original, and set the other UUID to be the same. At that point, we're going see any of them as the same drive... so you can swap them at will.

fredhoysted
03-27-2006, 09:25 AM
Thanks, Dave. Will proceed with care.

Fred

dnanian
03-27-2006, 09:29 AM
Sounds good, Fred. This isn't too hard to do, and it's not especially "dangerous". Just recognize that you shouldn't have both drives connected at the same time, since the system will think they're kind of the same... :-)

fredhoysted
04-12-2006, 10:20 AM
OK, Dave. I've now got my second drive and was just sitting down to do this. When I use terminal to run the command...

SDDiskTool -g /Volumes/Backup

I get an error: tcsh: SDDiskTool: Command not found.

Presumably there's some way to tell the shell about the existence of the program within the SuperDuper! bundle. Obviously double-clicking the program itself in the bundle from the Finder doesn't work as you can't specify the right arguments.

Maybe I'm not as advanced as I thought, but I'm happy to run terminal comamnds! Any tips please?

Thanks

Fred

dnanian
04-12-2006, 10:43 AM
It's inside the SD! bundle. So, cd into that:

cd /Applications/SuperDuper\!.app/Contents/MacOS

then, you have to precede it with ./:

./SDDiskTool -g /Volumes/some-disk-name

fredhoysted
04-12-2006, 12:12 PM
Cool. It seems to have worked, except that my final check shows a UUID that doesn't look right. Here's the transcript:

*** first, get the UUID from 'Backup' ***

[iMac:SuperDuper.app/Contents/MacOS] fredhoys% ./SDDiskTool -g /Volumes/Backup
887695BF46ADD874

*** then set the UUID of Backup2 = UUID of Backup ***

[iMac:SuperDuper.app/Contents/MacOS] fredhoys% ./SDDiskTool -s 887695BF46ADD874 /Volumes/Backup2

*** then check the UUID of Backup2 has been set correctly ***

[iMac:SuperDuper.app/Contents/MacOS] fredhoys% ./SDDiskTool -g /Volumes/Backup2
0000000000000000

All zeros.

I have a good backup on drive='Backup' so can re-initialise drive='Backup2' if I've done something horribly wrong....

Thanks again,

Fred

dnanian
04-12-2006, 12:24 PM
That's because you didn't do the "sudo":

sudo ./SDDiskTool -s 887695BF46ADD874 /Volumes/Backup2

fredhoysted
04-12-2006, 12:30 PM
Hmm. But see this:

[iMac:SuperDuper.app/Contents/MacOS] fredhoys% sudo ./SDDiskTool -s 887695BF46ADD874 /Volumes/Backup2
Password:
[iMac:SuperDuper.app/Contents/MacOS] fredhoys% sudo ./SDDiskTool -g /Volumes/Backup2
0000000000000000

dnanian
04-12-2006, 12:32 PM
That's strange, Fred. Try unmounting the other drive with the same UUID before setting this one.

fredhoysted
04-12-2006, 01:33 PM
It is strange. I had done that, actually, but have gone through the whole process again, just to be sure. Same result.

Interestingly, if I use Disk Utility to examine the second drive, it reports a 'Connection ID' (which I assume is the same as the UUID -- they both have 16 digits) of 4707151016748051 indicating that the first command didn't actually zero it.

My assumption could be wrong of course...

Fred

dnanian
04-12-2006, 01:44 PM
Not sure what the "connection ID" is, but the UUID is in the Get Info window for the drive. You don't want to use the # in the "device tree".

You can also try finding the disk identifier in that GetInfo window, then using hfs.util to get the UUID. To do so, you'd take the identifier (e.g. "disk2s10"), and run:

/System/Library/Filesystems/hfs.fs/hfs.utl -k disk2s10

fredhoysted
04-12-2006, 02:38 PM
Ah ha! Need to reformat it as a Mac OS HFS+ volume. Obvious now, but just shows that you can't use this drive (a Maxtor One Touch II) out of the box, at leaast not for this.

Thanks for your help.

Fred

dnanian
04-12-2006, 02:50 PM
Ah: didn't know you hadn't done that, Fred! Great -- glad you're all set.