View Full Version : Mac OS 9 - Flashing Question Mark

09-01-2004, 05:57 PM
I'm having an issue with getting an iMac (G3/700) on which the hard drive has been 'restored' with SuperDuper from a drive image created from an identical machine to startup in Mac OS 9. I'm getting the infamous 'Disk with the flashing question mark" icon after selecting Mac OS 9 as the startup operating system.

The machine has an installation of Mac OS X 10.2 that boots fine, but Mac OS 9 will not (although it does on the original machine from which the disk image was created).

I'm not sure if it matters, but both the backup and the restore were done with both the source and target machines in FireWire disk mode (with SuperDuper runnning on my PowerBook (Al, 1GHz).

Any help would be appreciated...

09-01-2004, 05:59 PM
When you select Mac OS9, do you do so from the Option-boot screen, or from System Preferences? Can you give both a try?

09-15-2004, 07:04 PM
I'm dealing with the same problem under pretty much the same circumstances. Best I've seen so far (from another site) was a suggestion to run DiskWarrior on the affected computer. Will try this tomorrow.

09-15-2004, 07:40 PM
Can you check what I asked ScottA, morganrt? How are you trying to boot OS9?

09-16-2004, 09:56 AM
Hi, I've tried Disk Warrior now, but still no luck. I've started it by selecting OS9 from the start up disk in (an old version of) OSX. Boots fine in OSX. I've tried it from the Option startup as well. Strangely, the icon in the option startup window shows the OS9 symbol. Normally, it will show X if both are on the disk. Norton doesn't find anything either. Sorry not much help. Files on disk are all readable, so will probably put onto a cd/dvd for archive. A solution or explanation would be helpful, though.

09-16-2004, 10:10 AM
I'm not sure what's going on here, moranrt -- we copy all the files we're supposed to, and I can boot OS9 here on OS9 capable machines. This must have something to do with your machine -- I assume it's also an older iMac?

I'll do some more research here and see what I can figure out. I don't have an old iMac around, unfortunately, but there might be something documented in the Apple Tombs ;) that will help.

Does "Classic" still run on this machine? Do me a favor and please send a OS X "System Profiler" report to the support -at- shirt-pocket -dot- com address, along with any additional information you feel is relevant. That'll help me get a handle on your machine configuration.

Sorry for the difficulty -- hopefully we'll be able to figure this out!

11-13-2004, 10:19 AM
I too, have an iMac. This one a g3/400. I used SuperDuper to clone the drive to another Mac (in this case an iMacG5). I did this so that I could then replace the hard drive of the older iMac. I replaced the drive, jumper set to master, partitioned it, installed os9 drivers and then proceded to clone back. All seemed to go well. OSX started right up. Classic worked fine. All applications in x and 9 worked. Then I tried to boot from OS9, which this computer had no problem doing before. When I did, I too, got the flashing question mark over a floppy icon.
The system folder appears to be blessed.
I tried booting from a known good OS9 bootable CD succesfully.
I've tried just copying over from the disk image to the G3 using FwTarget DM. No change. I've tried 'reblessing' the system folder by moving out and back in the system and finder. No change. I've run TTPro4, all tests. No change.
I've re-reformatted the drive to a single partition (originally had 2).
No luck.
What could be the problem?

11-13-2004, 10:53 AM
If you erased the drive with SuperDuper!, it's likely the problem is that the drive wasn't formatted to include OS9 drivers (SuperDuper, being an OS X tool, erases and does not install OS9 drivers on the drive). To work around this, I'd suggest using Disk Utility to erase and install OS9 drivers, and then use SuperDuper!, in Smart Update mode, to copy the data to the drive.

It's also possible that you need to re-select the boot volume, which is no longer known by the system's PRAM. Try booting with Option held down, and select the boot volume. You might also be able to clear PRAM with Cmd-Option-P-R during boot to get it to re-select the drive...