View Full Version : Back on the Spotlight merry-go-round

02-25-2006, 05:33 PM
I recently had to repartition the drive I use to backup my main hdd and now I am back in the frustrating position of trying to get Spotlight to not index it :mad: . I add it to the privacy list but it appears SD is re-enabling indexing? This is taken from the log -

| 09:22:40 PM | Info | ......COMMAND => Restoring Spotlight search indexing state on Backup
| 09:22:41 PM | Info | /Volumes/Backup:
| 09:22:41 PM | Info | Indexing disabled for volume.
| 09:22:41 PM | Info | /Volumes/Backup:
| 09:22:41 PM | Info | Could not set indexing status for volume.
| 09:22:41 PM | Info | Indexing enabled on Backup

I have tried deleting the .Spotlight folder and turning indexing off using mdutil etc. but for some reason it gets taken out of the privacy list when SD finishes.

Any ideas?

02-25-2006, 05:44 PM
OK, Russell. Don't turn off Indexing. Try deleting the .Spotlight_V100 folder, then restarting the system. Then, add it to the Spotlight privacy tab.

We'll preserve that setting. Don't turn indexing off, though -- you want to put it in privacy... otherwise, it still gets searched. As long as you're using 10.4.3 or later, it should be properly preserved.

Hope that helps.

02-26-2006, 06:23 AM
Many thanks, that appears to have sorted it, I can stop banging my head on the desk now :)

02-26-2006, 09:37 AM
Ah, good. That can start to hurt after a while!