Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Scheduled Copies Not Working (http://www.shirt-pocket.com/forums/showthread.php?t=6670)

Ric 07-27-2012 09:44 AM

Scheduled Copies Not Working
 
My scheduled copies have not worked since upgrading to Mountain Lion 10.8 and SuperDuper! 2.7. The copy is supposed to happen at 3:15 am, but when I checked my MacBook Pro at 7 am this morning, SuperDuper! was hanging with the spinning progress indicator in the Scheduled Copies window. I closed SD and then reopened it. I selected Copy Now in the Scheduled Copies window and SD crashed. I reopened SD, tried the same thing and it hung up again.

I have deleted and recreated the scheduled job. If I select Copy Now from the main SD window, Smart Update executes fine.

Here is what I see in the console log:

7/27/12 9:33:23.211 AM SuperDuper![2347]: ***ERROR OCCURRED: dyld: DYLD_ environment variables being ignored because main executable (/Applications/SuperDuper!.app/Contents/MacOS/SDAgent) is setuid or setgid
7/27/12 9:33:33.659 AM SuperDuper![2347]: -[__NSCFString _invalidateGStatesForTree]: unrecognized selector sent to instance 0x267ae70
7/27/12 9:33:33.660 AM SuperDuper![2347]: An exception was thrown during execution of an NSScriptCommand...
7/27/12 9:33:33.660 AM SuperDuper![2347]: -[__NSCFString _invalidateGStatesForTree]: unrecognized selector sent to instance 0x267ae70

dnanian 07-27-2012 09:52 AM

Are you sure you were logged in and "in front"?

Ric 07-27-2012 10:08 AM

Yep, I was definitely logged in.

Interestingly, I get the message 'dyld: DYLD_ environment variables being ignored because main executable (/usr/bin/login) is setuid or setgid' every time I open terminal. In researching that message, I discovered that it has been reported to Apple as a bug with Mountain Lion.

dnanian 07-27-2012 10:09 AM

Please send the full crash logs to me at support and I'll take a look. We've had no other reports of this...

Ric 07-27-2012 10:24 AM

I just sent the latest crash log.

TimLawson 07-30-2012 03:42 AM

Quote:

Originally Posted by dnanian (Post 31741)
Please send the full crash logs to me at support and I'll take a look. We've had no other reports of this...

Actually, Dave, it's been happening to me but I've only just had the time to deal with it. My log only shows the last successful backup which I did manually this morning as the scheduled one didn't run again at 10.30pm last night. I'll send the log to you tomorrow when I see if it's not worked again as I suspect.

The reason I have noticed this behaviour is because I schedule my iMac to power on in the mornings at 8.00am every day and then schedule SD! to backup and shut down the iMac every day at 10.30pm. Therefore, on those occasions that I've got to the office before 8.00am, I've wondered why my machine is on. Checking SD!'s 'scheduling pane' shows that the backup didn't run. Others may not be noticing this behaviour as there may be no visual alert unless they actually bother to check whether or not their scheduled backup has worked and that maybe why you've not had any other reports to date.

Now, I did yesterday schedule a backup for two minutes after the time I made the schedule and everything worked just fine so I'm now wondering if the issue is perhaps because SD! is not waking the computer from sleep...?

dnanian 07-30-2012 07:18 AM

SD! doesn't wake the computer from sleep, Tim. You have to set a wake event for one minute before the scheduled copy time.

(Totally different than Ric's report - which we've only had the one example of so far.)

TimLawson 07-30-2012 10:24 AM

Quote:

Originally Posted by dnanian (Post 31767)
SD! doesn't wake the computer from sleep, Tim. You have to set a wake event for one minute before the scheduled copy time.

(Totally different than Ric's report - which we've only had the one example of so far.)

Sorry if this is not within your remit, but how do I do that, Dave?

Also, what I'm experiencing doesn't seem so radically different to that which Ric's experiencing to me... my 10.30pm scheduled SD! backup doesn't run - I was only wondering if waking from sleep could have been the issue which you indicate isn't likely. The only time I've managed to get SD! to run a scheduled copy was the instance where I set it for two minutes into the future and then sat and watched it launch.

I've just created a new schedule, put my iMac to sleep and waited to see what would happen. The event did not run. I awoke the computer with a key press, noticed that the time was four minutes after my newly scheduled run time for SD! and then SD! launched with a message dialog stating that copying would take place in 10 seconds. I cancelled this. Let me know if you'd like me to reproduce it so as to be able to send you a log file.

Anyway, if you could let me know how to set a wake event, I'll try that and let you know how I get on after having set that up.

TimLawson 07-30-2012 10:29 AM

Quote:

Originally Posted by TimLawson (Post 31773)
Anyway, if you could let me know how to set a wake event, I'll try that and let you know how I get on after having set that up.

Sorry Dave - just done some more reading and seen how to set a new wake event. My bad. Only problem is, I use the one available wake event in System Prefs Energy Saver pane to start my iMac every day. I need this in case I'm away so that I can VPN to my machine.

Is there another way to create a wake event - an Apple script perhaps? I don't know ho to do such a thing myself...

dnanian 07-30-2012 10:37 AM

There likely is - perhaps using pmset (command-line utility) or a 3rd party tool that sets wake events...

TimLawson 07-30-2012 12:52 PM

Quote:

Originally Posted by dnanian (Post 31776)
There likely is - perhaps using pmset (command-line utility) or a 3rd party tool that sets wake events...

Thanks Dave. I don't think pmset allows for additional wakeup events beyond what may already be set as in my case. I did find this solution <http://www.dssw.co.uk/powermanager/standard/> which I don't want to try (too expensive / overkill for my needs) but may work so I'm reporting it here in case it helps others.

The weird thing is that my exact same shedule worked perfectly with Lion so I don't know what's changed. Anyway, I'm going to be scheduling SD! for a few minutes after booting in the morning when I know the iMac will be awake.

Many, many thanks for SD! - I couldn't live without it.

Ric 09-02-2012 07:28 AM

I finally tracked this down and all is working now.

Years ago, I installed Oracle Instant Client on my MacBook Pro and to get it working with PHP, I had to set a global DYLD environment variable in '/etc/launchd.conf'. Oracle Instant Client doesn't work with Lion or Mountain Lion and I had stopped using it. Apparently, Mountain Lion didn't like the environment variable, so I deleted launchd.conf, since it wasn't needed anymore.

Now, SuperDuper! scheduled copies are working and I'm not getting the DYLD message in my terminal sessions.

dnanian 09-02-2012 02:03 PM

Interesting. Thanks.


All times are GMT -4. The time now is 08:24 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.