Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   External firewire drive fails to boot OS X after a restart (http://www.shirt-pocket.com/forums/showthread.php?t=4618)

LEOinDC 09-29-2008 08:47 AM

External firewire drive fails to boot OS X after a restart
 
I have a G4 Cube that exhibits a perplexing boot issue on an external firewire drive. The external drive is a clone of the Cube's internal dual boot, two partition drive made with an identical 120 GB Seagate. The internal drive boots without incident into either OS X or OS 9 - each in it's own partition.

The problem comes when I select the external drive's OS X partition in Startup Disk and restart - the external drive's activity LED shows an initial attempt to boot but then hesitates and boots to the internal OS X partition repeatedly.

As a workaround, I am able to select and boot to the OS 9 partition, either internally or externally, launch the StartUp Disk control panel, select the external OS X partition and reboot successfully into that partition. But upon a restart, it fails to boot into the external OS X partition repeating the aforementioned behavior i.e. it boots to the internal OS X partition.

Using Option-Restart shows the the two partitions on the external drive and the two partitions on the internal drive normally but will only successfully process selecting either of the two OS 9 partitions or the internal OS X partition, again failing to process a selection to the external OS X partition.

Interestingly, this same external firewire drive will repeatedly boot to it's OS X partition without incident using either of two iBook G4s.

I'm stumped!

dnanian 09-29-2008 08:59 AM

It's possible that the Cube's older hardware doesn't support startup from this particular drive: anyone else out there using SD! with a Cube who could offer some advice?

LEOinDC 09-29-2008 09:08 AM

Quote:

Originally Posted by dnanian (Post 21727)
It's possible that the Cube's older hardware doesn't support startup from this particular drive...

That's the kicker - it WILL boot to the external OS X partition, but only after selecting it from a running OS 9 partition first.

It repeatedly fails after subsequent restarts until you repeat the selection process from a running OS 9 partition again.

dnanian 09-29-2008 09:33 AM

Sorry, I mis-read that. Weird. I have no idea why that would be... doesn't sound like spinup, because the drive appears in the list.


All times are GMT -4. The time now is 07:10 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.