Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Trouble with scheduled backups (http://www.shirt-pocket.com/forums/showthread.php?t=3610)

rithban 02-12-2008 12:10 PM

Trouble with scheduled backups
 
I've been pulling my hair out over this for some time, so I'm going to bare my ignorance here. I think I may have been staring at the manual too long and must be missing something that is staring me in the face. Sorry!

I'm trying to get scheduled backups to work, but have been unable thus far.
1) In the "Energy Saver" preferences -> Schedule, I have the computer set to wake at 3:29 (AM).
2) I have four backups scheduled daily, one at 3:30 AM, 4:30 AM, 5:30 AM, and 6:30 AM to ensure they don't overlap. A manual backup takes ~20 minutes. The four backups do a rotation across four partitions.
3) At night I leave the computer on, turning off the external monitor and dimming the MacBook Pro's display all the way.
4) ... ? [insert obvious thing I'm missing]

In the morning the "Scheduled Copies" show nothing new under "last copy". I then do a manual backup. This wastes time in the morning.

What am I misunderstanding?

dnanian 02-12-2008 01:05 PM

Try setting a copy to run a few minutes from "now". Does that work?

rithban 02-13-2008 03:04 AM

I should have thought about doing that for testing. *massive duh*

No, it doesn't seem to work. I set it for a few minutes in the future, and have waited for a few minutes after the set time. I tried shutting down SD, leaving it open, leaving it open with the scheduling window.

rithban 02-13-2008 03:18 AM

1 Attachment(s)
I can use the "Copy Now" button on the "Scheduled Copies" window to trigger SD, but the timer portion doesn't work.

One non-standard thing I can think of is Preferences > International > Formats > Region is set to "Japan (Japanese)". I'm learning Japanese, but I don't know enough to set *everything* to Japanese. Only the date/times are in Japanese.

I also have the backup partitions partially labeled in Japanese. See attached window snapshot.

I have no idea whether this would affect things. I assume not, but I might be useful.

dnanian 02-13-2008 08:32 AM

Rename the source and backup volumes to "standard" ASCII, then re-schedule. I think that'll fix it.

rithban 02-16-2008 11:17 PM

I've played with this some. If I use 7-bit ASCII, then the scheduling works. If I don't, the scheduling doesn't work. Is this a bug or OS X limitation?

If from the "Scheduled Copies" window, I press "Copy Now", it works with or without the 7-bit ASCII limitation. It only seems to be the scheduled run that has trouble.

Thank you for the tip. I'd rather be able to type something short rather than "Backup Day Before Yesterday 2". For the time being I'll put up with it just so the darned scheduled backups run.

dnanian 02-17-2008 09:40 AM

It's a known problem in the scheduler having to do with AppleScript, shell script, crontabs and a bunch of complicated stuff that seems to be broken in some OSX builds and not others... hopefully the workaround isn't too painful for now.


All times are GMT -4. The time now is 05:20 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.