Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Operation not permitted error (http://www.shirt-pocket.com/forums/showthread.php?t=3548)

truston 02-06-2008 08:59 PM

Operation not permitted error
 
Greetings,

I'm having a problem with SD! 2.5 which did not occur with 2.1.4. (Granted I'm running Leopard now, and have not cloned with 2.1.4 since upgrading.) I'm trying a straight full clone of my boot drive to a secondary hard drive, erasing the target first. The clone fails in the copy step roughly half to 3/4's of the way through, with this error in the log:

| 06:41:16 AM | Info | -rw-r--r-- 1 0 501 - 0 Feb 6 06:41 /Volumes/Backup HD/usr/share/terminfo/51/Q310-vip-w-am
| 06:41:16 AM | Error | SDCopy: Error "Operation not permitted" encountered while setting HFS meta data for /Volumes/Backup HD/usr/share/terminfo/51/Q310-vip-w-am of type: 8\n: Operation not permitted

Looking at the files in that directory from Terminal, they don't look quite right:

bluefin:51 truston$ ls -l
total 0
---------- 52941 root wheel 0 Jan 29 2005 Q306-8-pc
---------- 52942 root wheel 0 Jan 29 2005 Q310-vip-H
---------- 52942 root wheel 0 Jan 29 2005 Q310-vip-H-am
---------- 52945 root wheel 0 Jan 29 2005 Q310-vip-Hw
---------- 52946 root wheel 0 Jan 29 2005 Q310-vip-w
---------- 52946 root wheel 0 Jan 29 2005 Q310-vip-w-am

Any ideas what's awry here? I've run repair permissions with no change and no errors. I've cloned this drive with CCC without a problem (though I fully understand that doesn't mean it worked). I'll run Disk First Aid and see what it says. But I'd appreciate any insight into what the issue may be. Thanks!

- Todd
(Running SD! 2.5 on a PowerMac G5, on OS X 10.5.1)

dnanian 02-06-2008 09:35 PM

I believe those are all dead/broken links, Todd... they don't look like "good" files to me.

truston 02-07-2008 01:06 AM

Indeed. Disk Utility reports "Incorrect number of file hard links". Repair attempt claimed success, but those files still look wonky in the shell. Luckily, they're all in that terminfo path except for four /usr/bin executables, i.e. no critical user data is affected. Looks like I'll be doing a rebuild of this system soon. Thanks for your time.

-Todd


All times are GMT -4. The time now is 08:21 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.