PDA

View Full Version : Problems with scheduled backups in Lion (retail release)


almeath
07-27-2011, 04:47 AM
I had two administrator enabled accounts in Snow Leopard. I kept both accounts logged in all the time. SuperDuper was installed in both accounts with separate preferences.

In the 1st account I had scheduled smart-backup to run each night at 10:00pm. In the 2nd account the scheduling preferences had been left blank, as I only wanted the backup routine to run from the 1st account.

This worked fine in Snow Leopard. I could use the 2nd account without interruption while the backup routine ran in the background on the 1st account.

After upgrading to Lion, something strange has happened. Each night at 10:00pm SuperDuper will launch itself in the 2nd account (the one with no scheduled backups in the preferences) if that account happens to be in the foreground, and run the smart-backup sequence. When I check in the 1st account, the preferences are unaltered and still set to backup each night. Yet, SuperDuper does not launch itself in the 1st account.

In summary, SuperDuper is launching itself in the 2nd account that is in the foreground, while still using the preferences of the 1st account in the background.

What I have not yet tested is whether the backup sequence will start at 10:00pm in the 1st account if that account happens to be in the foreground.

dnanian
07-27-2011, 07:23 AM
Given that SuperDuper! uses the crontab of the scheduled account to run, and we launch normally, it sounds like SD! comes up "over" the other account, but is actually running in the 1st account. You can probably check this by looking at the owner of the process in Activity Monitor.

That'd certainly be a bug in Lion, but I don't know what we could really do about it other than report it...

almeath
07-28-2011, 10:31 PM
Thank you. I did suspect it was yet another bug in Lion...

I think you're right that not much can be done. It's one of those annoying rather than disruptive problems, so I'll wait and see if 10.7.1 fixes it.

dcwinton
07-30-2011, 03:17 PM
I have one account in action on my Mac. I am running SD! 2.6.4. I have been using SD without incident for about 3 years (first on one machine, and now on a new iMac 27" 2.8 gHz w/ 8gb ram and a 1 tb HDD).

I run two SmartUpdates of the boot drive every night, one to external drive A at 1:30 am, and another to external drive B at 4:30 am. The next night, I switch out A and replace with external C, so that every morning there are two complete fresh backups and a third backup that is no more than a day old.

Just upgraded to Lion this week. Since upgrade, all scheduled SmartUpdates have failed. I have rebooted several times, and reset the SMC (or whatever it's called) twice.

Any thoughts? Thank you.

dnanian
07-30-2011, 03:33 PM
Please send your log in with the "Send to shirt pocket" button. Thanks.

dcwinton
07-30-2011, 09:11 PM
Log says couldn't log in because pw required. Doh. That setting seems to have changed itself because I ALWAYS have that set to no. Change, and will see what happens. Log sent anyhow. Thank you Dave.

dnanian
07-31-2011, 08:19 AM
Ah, OK - not unlocked in the main window, I assume...