PDA

View Full Version : Disabeling Spootliht on the backup drive doesn't work


ma012
10-31-2008, 10:41 AM
In the FAQ article "How do I disable spotlight for my backup drive?", you write :

As of v2.0, when used with Tiger 10.4.3 or later, it's quite easy: just add the volume to the Privacy tab of the Spotlight preference pane. We'll automatically ensure that that state is maintained, and all should work fine.

I'm using SuperDuper! v2.5 under MacOS 10.5.5.

When I make a full backup of my internal drive on an external drive called "Backup 1", the external drive is in the privacy tab of Spootlight on the internal drive. But after the backup, the drive "Backup*1" doesn't contain in its privacy tab the name "Backup 1" so Spootlight is enabled and I have to add the drive manually to the list.

What can I do to add it automatically ?

dnanian
10-31-2008, 11:03 AM
Are you using the 'disable_spotlight' script? We do not touch the .Spotlight_V100 folder under v2.5 at all, so any settings in there (including the privacy state) should be maintained.

ma012
11-01-2008, 03:53 AM
Are you using the 'disable_spotlight' script? We do not touch the .Spotlight_V100 folder under v2.5 at all, so any settings in there (including the privacy state) should be maintained.

I'm not using the 'disable_spootlight' script.

I specify that Spootlight is disabled on the internal drive. But all my backup drives are listed in the privacy tab of Spootlight on this drive.

dnanian
11-01-2008, 06:52 AM
How do you disable on the internal? Adding to privacy (the right way)?

ma012
11-01-2008, 08:48 AM
How do you disable on the internal? Adding to privacy (the right way)?

No, the internal drive is not in the privacy tab.

I've typed in the terminel : sudo mdutil -i off /volumes/InternalVolume

dnanian
11-01-2008, 08:57 AM
OK. Turn indexing on in Terminal and use Privacy instead... let's see if that works better for you.

ma012
11-01-2008, 11:11 AM
OK. Turn indexing on in Terminal and use Privacy instead... let's see if that works better for you.

I did it. But it still doesn't work.

I've turned indexing on in the Terminal. The internal drive and the backup drive were both in the privacy tab. After a full backup, when SuperDuper! restarts on the backup drive, this one it is not in the privacy tab and Spootliht is enabled on it.

dnanian
11-01-2008, 11:20 AM
After the backup, if you don't restart from the backup drive, is the drive in Privacy?

ma012
11-01-2008, 11:28 AM
After the backup, if you don't restart from the backup drive, is the drive in Privacy?

Yes, it is. On the internal drive (the source drive).

dnanian
11-01-2008, 11:35 AM
OK. It sounds like OSX invalidates the privacy status when the drive 'changes paths' -- that is, its mount point changes from, say "/" to "/Volumes/Macintosh HD", which is what's going on there. It's a quirk of Spotlight. But the state does sound like it's being properly preserved by SD...

ma012
11-01-2008, 11:56 AM
OK. Thank you.