PDA

View Full Version : Repeatedly crashing dock from Leopard clone


strells
06-11-2008, 10:26 PM
This is the second clone that this has happened with: When booting with the clone, I get a repeatedly crashing dock. After a while or a few Finder relaunches, it works normally, but it is very frustrating and I can't find a solution. Could it be something in my dock causing the problem? But then why is it only on a clone that my dock crashes? Help! Here is one of the console logs of the crash:

Process: Dock [729]
Path: /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
Identifier: com.apple.dock
Version: 1.6.3 (606)
Build Info: Dock-6060000~2
Code Type: X86 (Native)
Parent Process: launchd [398]

Date/Time: 2008-06-11 19:22:11.045 -0700
OS Version: Mac OS X 10.5.3 (9D34)
Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: 0x000000000000000d, 0x0000000000000000
Crashed Thread: 2

Thread 0:
0 dyld 0x8fe0e49e ImageLoader::containsAddress(void const*) const + 110
1 dyld 0x8fe06f22 dyld::bindLazySymbol(mach_header const*, unsigned long*) + 226
2 dyld 0x8fe18b6f stub_binding_helper_interface2 + 21
3 com.apple.ImageIO.framework 0x022c908a CFMutableDictAddProperty + 62
4 com.apple.ImageIO.framework 0x022c7989 _CGImagePluginInitPNG + 3974
5 com.apple.ImageIO.framework 0x022c653a makeImagePlus + 503
6 com.apple.ImageIO.framework 0x022c5efa CGImageSourceCreateImageAtIndex + 123
7 com.apple.dock 0x0000c051 0x1000 + 45137
8 com.apple.dock 0x0001375f 0x1000 + 75615
9 com.apple.dock 0x000394d3 0x1000 + 230611
10 com.apple.dock 0x00096ae5 0x1000 + 613093
11 com.apple.dock 0x000052fe 0x1000 + 17150

Thread 1:
0 libSystem.B.dylib 0x00cf768e __semwait_signal + 10
1 libSystem.B.dylib 0x00d2236d pthread_cond_wait$UNIX2003 + 73
2 com.apple.dock 0x000132a4 0x1000 + 74404
3 libSystem.B.dylib 0x00d216f5 _pthread_start + 321
4 libSystem.B.dylib 0x00d215b2 thread_start + 34

Thread 2 Crashed:
0 dyld 0x8fe18b42 misaligned_stack_error + 0
1 com.apple.SystemConfiguration 0x002208c0 SCNetworkConnectionPrivateGetPPPServiceFromDynamic Store + 135

Thread 2 crashed with X86 Thread State (32-bit):
eax: 0x00245473 ebx: 0x04b9b6f8 ecx: 0x00000000 edx: 0x04b9f000
edi: 0x00000000 esi: 0x00000000 ebp: 0x04b98f94 esp: 0x04b98f2c
ss: 0x0000001f efl: 0x00010212 eip: 0x8fe18b42 cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000000
cr2: 0x04b97000

dnanian
06-12-2008, 06:36 AM
Did you try the fix at the top of the forums?

strells
06-12-2008, 01:24 PM
Can I run this while booted from the cloned drive? Some of the responses in that thread seem to indicate that I shouldn't.

Steve

dnanian
06-12-2008, 02:12 PM
Well, if you can get to Terminal, you can certainly run the command in the shell script by hand...