PDA

View Full Version : paid attention a little too late


septicdeath
12-31-2007, 03:29 AM
I had been backing up my leopard install to a firewire drive as a sparseimage.
I hadnt had any problems so I never really needed to test it, and quite honestly, I haven't even been to the site to check out whats going on w/SD.
I lost my main harddrive last night. I have already replaced it with a new unit. Its just now that after I use the leopard install disk, and then disk utility(mount the sparse) and then use disk util restore to restore the leopard sparse and reboot that I obviously now know that my system doesn't boot.

I thought about installing a fresh copy and then using sudo commands from the cli and just copying * from the mounted sparse image to the new leopard install, but for some reason it just got all jacked up.

Anyone have any suggestions on the best way to do this, or is my sd created sparseimage of my leopard install just never going to be able to be restored from. What I'm asking, is the sparse image been created faulty, or is it that I need to use like CCC to restore the image to the internal hard-drive?

I actually am semi new to the mac, is it possible to just mount the sparse image and just copy the applications and user directories and restore everything this way?

I also have another usb disk with leopard install on it I can boot, so that my laptop internal is not used during booting if that helps.

Any suggestions would be great.

Thanks

John

dnanian
12-31-2007, 11:04 AM
What I'd do is copy the sparse image to another drive (directly to it), with the "ACL Copy" option in the Advanced tab of Options OFF. Then, clean install Leopard and -- when prompted -- migrate from the copy into the new install.

septicdeath
12-31-2007, 02:49 PM
Although I didn;t have the ACL's turned off, I did restore to the internal drive. (My sparse is 10.5.1) and my boot is 10.5.0, so I need to find 10.5.1 media.

Ohh... I think I just read what you said again. This would be a 3 drive swap. Install my sparse to a non internal drive, then install to internal and tell it to find other macintosh connected to system?

Thanks

dnanian
12-31-2007, 03:42 PM
That's what I'm suggesting, yes: a 3-drive (two external volumes) swap.

fdlcunha
12-31-2007, 08:49 PM
I am in the same situation. I have a complete HD clone done with SD! of my previous Leopard 10.5.1 internal HD. I was unaware SD was not fully compatible with Leopard, and I had to format my internal HD. So, now, how can I use my external HD backup to restore my internal HD? Is there any way to make my external clone bootable?
Please, do help me.
Happy New Year from Rio de Janeiro.

dnanian
12-31-2007, 09:11 PM
The solution would be the same as the above...

septicdeath
12-31-2007, 11:54 PM
I just posted a LONG helpful response on whats going on in my situation, but for somereason my message got lost and I had to re-log in, I cant find it in myself to retype that entire message again, I just cant.

So I will get quick and dirty.

I migrated into the fresh install, about 85% took. System Preference add-ons are all whack, luckly, little snitch wont run, but a re-install gained me access to all my network rules, theres a hour or so saved.

I am trying to run Entourage and cant get access to any of my identities (main and backups). Entourage is reporting "You dont have write access to the Entourage application folder. To run ... you must have administrator user remove identities folder from the application folder". I am the only user on my machine, minus the root user that I use from the cli and all my macports/xdarwin/fink stuff. (which btw, looks like a complete flush and recompile of all those apps is going to need to be done, unless some chown in the correct area is the only fix I need, DU verify permissions isn't reporting any issues, but I dont think its deep enough to fix these).

Any suggestion on which group to apply the sudo chown -R nicitaja:<GROUP> /Applications so that I dont mess up the system, but allow myself access where I should have access. Will take some time at the CLI and explore, maybe it will jump out at me and make sense. Why the migration didnt create these correctly, I dont know.

Firefox is jacked, re-install doesn't fix. It thinks that no Master Password is set, so when I try to change it, it doesn't allow me to input text in the old password box, so it fails, firefox complains every run, every access. Luckily, I use 1-password, so all my important information is there, to anyone else following my example, make sure you export your bookmarks the first time you run firefox, the more time you run it, the more messed up it seems to get. Just export, then TRASH, and re-install.

I have a question, its the actual creation of the sparseimage of 10.5 with SD thats messed up, its not like a updated SD is going to be able to successfully restore the already created image, if this is the case, I might be able to survive with this messed up system until I see a new SD, *BUT* every sense of developer in me tells me that since DiskUtil cant use the image to restore a bootable drive, that the problem was recorded with the backup, and its just never gonna be usable.

I am a lucky one, with for or five extra 300 gig usb drives lying around, but as you can see from above, this method is far from working, and in all honesty, if you have the original applications and key-codes, its probably faster to just start fresh, as I know you can successfully grab the /Users folder and data from the sparseimage, I'm not sure if you can grab the /Applications and just bring them out and into your existing install, but most all of my system preference are all jacked, and I'm going to need to re-install most all of those add-ons (speed download, visage, little snitch, perian, to name a few).

I hope I can get my old email back, as that entourage identity is 10 years of Microsoft Outlook, exported and brought to Entourage, and is my main concern. Luckly, the help seems to make it easy, you don't have permission to the Identity Folder in the installation, a simple folder to fix I think.

I'm the idiot that installed Leopard, and I will spend the rest of the night kicking myself in the A$$, err, wait, I need to use my 1 day off to fix my machine so that I can actually work when I need to go back on Jan 2nd. Its obvious that Apple, who spent so much money mocking Vista and all of its issues, then turned around and rushed out this INCOMPLETE, 3rd party NOT SUPPORTED, version of its OS, became that which they make fun of, and gave us all one big steamy pile. The internet should be filled with thousand... err oh ya, it is... Never mind.


Thanks for your help.

If anyone has a suggestion on the correct group to chown to fix permisison on the /Application folder, please let me know. DiskUtility fix permissions isnt catching it, but I dont think its deep enough to.

Thanks again.

dnanian
01-01-2008, 11:29 AM
My guess is that it's not standard ownership that's messed up -- I think you have incorrect ACLs, which is why I suggested that you make the copy with ACLs turned OFF (so you wouldn't have any), and then migrate. Is that what you did?

septicdeath
01-01-2008, 02:23 PM
I had the acl's turned off. Which is why it didnt make sense.

a chown -R nicitaja:nicitaja on /Users/nicitaja, and /Applicaitons/Library was all it took. Even fixed Firefox..

Still have broken System Preferences, but I am re-installing all of them one by one.

dnanian
01-01-2008, 02:24 PM
That's curious. I wonder why it didn't migrate those files with the user's ownership?

septicdeath
01-01-2008, 03:42 PM
Weird isn't it. I can only assume that at some time, Its possible I tweaked with permissions, I had the issue where the acl's suddenly started applying the hidden attribute and had to use dev tools to fix. Or maybe with all the macports and fink compilations, I might had hit a directory without recalling it.


Anyways, at least I am almost back to where I started. If I didn't need bootcamp, I would have thought about installing 10.4.11 and migrating into that (if its possible) leopard has been nothing but a pain in the ass. I ditched MS for OSX to get away from these type massive company wide dumbass moves, welcome to MS's world Apple, you've officially arrived. ;)

SD

dnanian
01-01-2008, 04:34 PM
It's definitely strange. Oh well, there's always something, regardless of OS, and we're still quite early in Leopard yet...