PDA

View Full Version : AM schedule reverts to PM


Nomad
12-20-2006, 06:38 AM
When scheduling a backup... SuperDuper will revert an AM time setting to a PM setting... right in front of my eyes. I'll set 5:30AM in the Scheduled Copies drawer hit OK then When I select the Schedule in the Scheduled Copies window it shows 5:30PM in the "What's going to happen?" text.

The BackUps then occur at 5:30PM as indicated. (but not desired) I've tried resetting this repeatedly by editing the schedule with no avail, it simply produces new schedule entries with the same mistake. (The "new" schedules that appear are also frustrating)

I ran crontab -l | pbcopy and this was the result:

30 17 * * * open file:///Users/dbVolly/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20Macinroe_FULL_MWF_temp\%20from\ %20fullcourt.sdsp/Copy\%20Job.app

- I trashed the .plist...
-Trashed the Application Support files....
- reinstalled the app from a fresh download.
Frustrating.

Also, the date format should follow the computer's date time format (24 hr Millitary Time in this case) or at least give us the option to set this in the prefs. I wouldn't have caught this if I hadn't happened to be on the server at 17:30 today. The Next Copy listing in the Scheduled copies only lists "Wed December 20 at 5:30" no indication of AM or PM. Quite Unprofessional.

Bloody Fantastic Product otherwise...

Thanks,

Jason

dnanian
12-20-2006, 09:32 AM
Can you give me more information about your international time settings so I can try to reproduce this? We do (or should) follow the short time format in the "Formats" menu...

Ric
02-07-2008, 12:24 PM
I guess I'll resurrect this thread because I observed the exact same behavior with 2.5 running on 10.5.1.

Until recently, I was using the default US region in the international settings. I recently customized the time display to a 24-hour format with no AM or PM display. My short format is '##:##'. After installing 2.5, I went to schedule a 3:18 (3:18 AM) backup. SuperDuper! kept interpreting this as 3:18 PM. As a workaround, I reverted back to the default US region date format and reopened SuperDuper!. There was now an AM or PM option in the time settings and it let me set my backup for 3:18 AM.

After I had saved the schedule, I went back into my international settings and changed back to the 24-hour format. My crontab entry has retained the correct time and the backups are firing off at 3:18 AM as they should.