PDA

View Full Version : scheduled backups are not running


katachi
06-21-2006, 12:24 AM
My computer has one admin account that I use to install programs and maintain the machine. My other users do their day-to-day work in regular user accounts.

SuperDuper! is installed, registered, configured, and scheduled via the admin account. I've noticed that my schedules (three of them: separate jobs for weekdays, Saturdays, and Sundays) are not running. The day the schedule is set to run continues to update (i.e. every day the schedule says it will run on that day), but my logs never show any activity. The log date is still from when I made the original "full" backup.

It's as if since I'm not logged into my admin account at the time of the scheduled job, SuperDuper! never runs.

I assumed that SuperDuper! scheduled its jobs via cron, and therefore should run system-wide regardless of who if anybody is logged in, so long as Mac OS X is running. What's going on? :confused:

dnanian
06-21-2006, 08:07 AM
Sorry for any confusion, katachi.

What's going on is exactly how it's documented: the backups are scheduled in the user's crontab, and thus will only run when the user is logged in and in front...

katachi
06-21-2006, 12:16 PM
Ooooooooh, OK.

I don't suppose there is any way for the jobs to be scheduled in root's crontab, and therefore run regardless of who is logged in?

dnanian
06-21-2006, 12:53 PM
If you install logged in as root, things should run. Be aware, though, that this is not an explicitly supported configuration.

(Also, if you choose to do this, send me email and I'll send you a fixed template that corrects a problem with 2.1.2 and root running.)