PDA

View Full Version : disable_spotlight won't die


lunaport
02-06-2006, 01:33 PM
Hi,

Now that SuperDuper! respects Spotlight's Privacy settings, I've deselected the "Run shell script after copy completes checkbox" and deleted the disable_spotlight shell script.

However, my backups now end with the following error:


| 12:19:11 PM | Info | ......COMMAND => Restoring Spotlight search indexing state on iMac Backup
| 12:19:11 PM | Info | /Volumes/iMac Backup:
| 12:19:11 PM | Info | Indexing disabled for volume.
| 12:19:12 PM | Info | /Volumes/iMac Backup:
| 12:19:12 PM | Info | Indexing enabled for volume.
| 12:19:12 PM | Info | Indexing enabled on iMac Backup
| 12:19:12 PM | Info | ...ACTION: Running shell script disable_spotlight
| 12:19:12 PM | Info | ......COMMAND => Invoking site customization script: /Applications/disable_spotlight
| 12:19:12 PM | Error | sh: line 1: /Applications/disable_spotlight: No such file or directory


Like I said, the "Run shell" checkbox is unchecked, but the path to my old disable_spotlight is still there, greyed-out, because I can't figure out any way to delete it. I even tried deleting my old settings and creating new ones from scratch, and the path to disable_spotlight was still there. Any idea how to fix this?

dnanian
02-06-2006, 01:49 PM
The path to the script will be there, but the problem here is more likely that you've got a scheduled setting, and you're manipulating things in the main window.

To get the scheduled item to update, you need to delete and recreate it.

Hope that helps!

lunaport
02-07-2006, 06:50 PM
Nope.

Deleted the scheduled copy, and the path is still there.

Deleted the saved settings, and the path is still there.

Deleted and reinstalled SuperDuper!, and the path is still there.

dnanian
02-07-2006, 06:56 PM
The path being there is different than it actually being acted upon, lunaport.

You can get rid of the greyed out path by removing the preferences (com.blacey.superduper!.plist), but it's not necessary if the settings that are running don't have the box checked...